You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-minidom0.12/SPECS/rust-minidom0.12.spec

97 lines
2.4 KiB

## START: Set by rpmautospec
## (rpmautospec version 0.3.0)
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 23
%bcond_without check
%global debug_package %{nil}
%global crate minidom
Name: rust-minidom0.12
Version: 0.12.0
Release: %autorelease
Summary: Small, simple DOM implementation on top of quick-xml
License: MPL-2.0
URL: https://crates.io/crates/minidom
Source: %{crates_source}
# Fix invalid test data with an IPv4 address containing octals
Patch: minidom-fix-ipaddr-test.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Small, simple DOM implementation on top of quick-xml.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+comments-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+comments-devel %{_description}
This package contains library source intended for building other packages which
use the "comments" feature of the "%{crate}" crate.
%files -n %{name}+comments-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.12.0-1
- Rebuilt for MSVSphere 9.3
* Thu Dec 29 2022 Michel Alexandre Salim <salimma@fedoraproject.org> 0.12.0-1
- Initial Fedora package