Signed-off-by: Michel Alexandre Salim <salimma@fedoraproject.org>epel9 imports/e9/rust-minidom0.12-0.12.0-1.el9
parent
77ced057f1
commit
3e28b84d24
@ -0,0 +1 @@
|
||||
/minidom-0.12.0.crate
|
@ -0,0 +1,14 @@
|
||||
Fix IpAddr test, since octal numbers are not allowed:
|
||||
|
||||
https://doc.rust-lang.org/std/net/struct.Ipv4Addr.html
|
||||
--- a/src/convert.rs
|
||||
+++ b/src/convert.rs
|
||||
@@ -84,7 +84,7 @@ mod tests {
|
||||
assert_eq!(18i32.into_attribute_value().unwrap(), "18");
|
||||
assert_eq!((-19i64).into_attribute_value().unwrap(), "-19");
|
||||
assert_eq!(
|
||||
- IpAddr::from_str("127.000.0.1")
|
||||
+ IpAddr::from_str("127.0.0.1")
|
||||
.unwrap()
|
||||
.into_attribute_value()
|
||||
.unwrap(),
|
@ -0,0 +1,83 @@
|
||||
# Generated by rust2rpm 23
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate minidom
|
||||
|
||||
Name: rust-minidom0.12
|
||||
Version: 0.12.0
|
||||
Release: %autorelease
|
||||
Summary: Small, simple DOM implementation on top of quick-xml
|
||||
|
||||
License: MPL-2.0
|
||||
URL: https://crates.io/crates/minidom
|
||||
Source: %{crates_source}
|
||||
# Fix invalid test data with an IPv4 address containing octals
|
||||
Patch: minidom-fix-ipaddr-test.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Small, simple DOM implementation on top of quick-xml.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+comments-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+comments-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "comments" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+comments-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue