initial import (#1948142)
parent
f687552ec5
commit
34c7a4b69d
@ -0,0 +1,4 @@
|
||||
/results_*/
|
||||
/*.src.rpm
|
||||
|
||||
/memsec-0.6.0.crate
|
@ -0,0 +1,25 @@
|
||||
--- memsec-0.6.0/Cargo.toml 2020-07-29T17:25:03+00:00
|
||||
+++ memsec-0.6.0/Cargo.toml 2021-04-12T09:26:20.491322+00:00
|
||||
@@ -21,6 +21,7 @@
|
||||
categories = ["no-std", "memory-management"]
|
||||
license = "MIT"
|
||||
repository = "https://github.com/quininer/memsec"
|
||||
+exclude = ["appveyor.yml"]
|
||||
[dependencies.getrandom]
|
||||
version = "0.1"
|
||||
optional = true
|
||||
@@ -29,13 +30,9 @@
|
||||
alloc = ["getrandom", "use_os"]
|
||||
default = ["use_os", "alloc"]
|
||||
nightly = []
|
||||
-use_os = ["libc", "winapi"]
|
||||
+use_os = ["libc"]
|
||||
[target."cfg(unix)".dependencies.libc]
|
||||
version = "0.2"
|
||||
-optional = true
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.3"
|
||||
-features = ["memoryapi", "sysinfoapi"]
|
||||
optional = true
|
||||
[badges.appveyor]
|
||||
repository = "quininer/memsec"
|
@ -0,0 +1,139 @@
|
||||
# Generated by rust2rpm 16
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate memsec
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.6.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Rust implementation of libsodium/utils
|
||||
|
||||
# Upstream license specification: MIT
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/memsec
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * Drop Windows-specific dependencies
|
||||
# * Exclude files only useful for upstream CI
|
||||
Patch0: memsec-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Rust implementation `libsodium/utils`.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+alloc-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+alloc-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "alloc" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+alloc-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+getrandom-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+getrandom-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "getrandom" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+getrandom-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+libc-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+libc-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "libc" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+libc-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+nightly-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+nightly-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "nightly" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+nightly-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+use_os-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+use_os-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "use_os" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+use_os-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Apr 12 2021 Fabio Valentini <decathorpe@gmail.com> - 0.6.0-1
|
||||
- Initial package
|
Loading…
Reference in new issue