You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-linux-raw-sys0.3/rust-linux-raw-sys0.3.spec

146 lines
3.7 KiB

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate linux-raw-sys
Name: rust-linux-raw-sys0.3
Version: 0.3.8
Release: %autorelease
Summary: Generated bindings for Linux's userspace API
License: Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
URL: https://crates.io/crates/linux-raw-sys
Source: %{crates_source}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Generated bindings for Linux's userspace API.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/COPYRIGHT
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-Apache-2.0_WITH_LLVM-exception
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CODE_OF_CONDUCT.md
%doc %{crate_instdir}/ORG_CODE_OF_CONDUCT.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+errno-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+errno-devel %{_description}
This package contains library source intended for building other packages which
use the "errno" feature of the "%{crate}" crate.
%files -n %{name}+errno-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+general-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+general-devel %{_description}
This package contains library source intended for building other packages which
use the "general" feature of the "%{crate}" crate.
%files -n %{name}+general-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ioctl-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ioctl-devel %{_description}
This package contains library source intended for building other packages which
use the "ioctl" feature of the "%{crate}" crate.
%files -n %{name}+ioctl-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+netlink-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+netlink-devel %{_description}
This package contains library source intended for building other packages which
use the "netlink" feature of the "%{crate}" crate.
%files -n %{name}+netlink-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+no_std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+no_std-devel %{_description}
This package contains library source intended for building other packages which
use the "no_std" feature of the "%{crate}" crate.
%files -n %{name}+no_std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog