You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-linux-raw-sys/SPECS/rust-linux-raw-sys.spec

314 lines
9.0 KiB

## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate linux-raw-sys
Name: rust-linux-raw-sys
Version: 0.4.12
Release: %autorelease
Summary: Generated bindings for Linux's userspace API
License: Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
URL: https://crates.io/crates/linux-raw-sys
Source: %{crates_source}
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Generated bindings for Linux's userspace API.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/COPYRIGHT
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-Apache-2.0_WITH_LLVM-exception
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CODE_OF_CONDUCT.md
%doc %{crate_instdir}/ORG_CODE_OF_CONDUCT.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+elf-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+elf-devel %{_description}
This package contains library source intended for building other packages which
use the "elf" feature of the "%{crate}" crate.
%files -n %{name}+elf-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+errno-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+errno-devel %{_description}
This package contains library source intended for building other packages which
use the "errno" feature of the "%{crate}" crate.
%files -n %{name}+errno-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+general-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+general-devel %{_description}
This package contains library source intended for building other packages which
use the "general" feature of the "%{crate}" crate.
%files -n %{name}+general-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+if_ether-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+if_ether-devel %{_description}
This package contains library source intended for building other packages which
use the "if_ether" feature of the "%{crate}" crate.
%files -n %{name}+if_ether-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+io_uring-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+io_uring-devel %{_description}
This package contains library source intended for building other packages which
use the "io_uring" feature of the "%{crate}" crate.
%files -n %{name}+io_uring-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ioctl-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ioctl-devel %{_description}
This package contains library source intended for building other packages which
use the "ioctl" feature of the "%{crate}" crate.
%files -n %{name}+ioctl-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+mempolicy-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+mempolicy-devel %{_description}
This package contains library source intended for building other packages which
use the "mempolicy" feature of the "%{crate}" crate.
%files -n %{name}+mempolicy-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+net-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+net-devel %{_description}
This package contains library source intended for building other packages which
use the "net" feature of the "%{crate}" crate.
%files -n %{name}+net-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+netlink-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+netlink-devel %{_description}
This package contains library source intended for building other packages which
use the "netlink" feature of the "%{crate}" crate.
%files -n %{name}+netlink-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+no_std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+no_std-devel %{_description}
This package contains library source intended for building other packages which
use the "no_std" feature of the "%{crate}" crate.
%files -n %{name}+no_std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+prctl-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+prctl-devel %{_description}
This package contains library source intended for building other packages which
use the "prctl" feature of the "%{crate}" crate.
%files -n %{name}+prctl-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+system-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+system-devel %{_description}
This package contains library source intended for building other packages which
use the "system" feature of the "%{crate}" crate.
%files -n %{name}+system-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+xdp-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+xdp-devel %{_description}
This package contains library source intended for building other packages which
use the "xdp" feature of the "%{crate}" crate.
%files -n %{name}+xdp-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Wed Jan 10 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.4.12-1
- Rebuilt for MSVSphere 9.3
* Fri Dec 01 2023 Fabio Valentini <decathorpe@gmail.com> - 0.4.12-1
- Update to version 0.4.12
* Thu Nov 09 2023 Fabio Valentini <decathorpe@gmail.com> - 0.4.11-1
- Update to version 0.4.11
* Sat Oct 07 2023 Fabio Valentini <decathorpe@gmail.com> - 0.4.8-1
- Update to version 0.4.8
* Sun Sep 17 2023 Fabio Valentini <decathorpe@gmail.com> - 0.4.7-1
- Update to version 0.4.7
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.8-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Mon May 22 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.8-1
- Update to version 0.3.8; Fixes RHBZ#2208687
* Mon May 08 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.7-1
- Update to version 0.3.7; Fixes RHBZ#2193043
* Fri Apr 28 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.6-1
- Update to version 0.3.6; Fixes RHBZ#2188142
* Wed Apr 19 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.2-1
- Update to version 0.3.2; Fixes RHBZ#2187774
* Mon Apr 10 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.1-1
- Update to version 0.3.1; Fixes RHBZ#2153035
* Mon Feb 06 2023 Fabio Valentini <decathorpe@gmail.com> - 0.1.4-1
- Update to version 0.1.4
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Sun Dec 11 2022 Fabio Valentini <decathorpe@gmail.com> - 0.1.3-1
- Update to version 0.1.3; Fixes RHBZ#2112533
* Thu Oct 27 2022 Fabio Valentini <decathorpe@gmail.com> - 0.0.46-1
- Update to version 0.0.46
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.42-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Tue Apr 12 2022 Fabio Valentini <decathorpe@gmail.com> - 0.0.42-1
- Update to version 0.0.42
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.36-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Sun Nov 28 2021 Olivier Lemasle <o.lemasle@gmail.com> - 0.0.36-1
- Bump to upstream 0.0.36
* Thu Sep 23 2021 Olivier Lemasle <o.lemasle@gmail.com> - 0.0.28-1
- Bump to upstream 0.0.28
* Fri Jul 16 18:55:15 CEST 2021 Olivier Lemasle <o.lemasle@gmail.com> - 0.0.16-1
- Initial package