You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
41 lines
1.3 KiB
41 lines
1.3 KiB
--- libsqlite3-sys-0.18.0/Cargo.toml 2020-04-23T16:47:20+00:00
|
|
+++ libsqlite3-sys-0.18.0/Cargo.toml 2020-11-27T23:49:05.335742+00:00
|
|
@@ -23,8 +23,7 @@
|
|
license = "MIT"
|
|
repository = "https://github.com/rusqlite/rusqlite"
|
|
[build-dependencies.bindgen]
|
|
-version = "0.53"
|
|
-features = ["runtime"]
|
|
+version = "0.56"
|
|
optional = true
|
|
default-features = false
|
|
|
|
@@ -37,21 +36,15 @@
|
|
optional = true
|
|
|
|
[features]
|
|
-buildtime_bindgen = ["bindgen", "pkg-config", "vcpkg"]
|
|
-bundled = ["cc", "bundled_bindings"]
|
|
-bundled-windows = ["cc", "bundled_bindings"]
|
|
-bundled_bindings = []
|
|
-default = ["min_sqlite_version_3_6_8"]
|
|
+buildtime_bindgen = ["bindgen", "pkg-config"]
|
|
+default = ["min_sqlite_version_3_6_8", "buildtime_bindgen"]
|
|
in_gecko = []
|
|
-min_sqlite_version_3_6_23 = ["pkg-config", "vcpkg"]
|
|
-min_sqlite_version_3_6_8 = ["pkg-config", "vcpkg"]
|
|
-min_sqlite_version_3_7_16 = ["pkg-config", "vcpkg"]
|
|
-min_sqlite_version_3_7_7 = ["pkg-config", "vcpkg"]
|
|
+min_sqlite_version_3_6_23 = ["pkg-config"]
|
|
+min_sqlite_version_3_6_8 = ["pkg-config"]
|
|
+min_sqlite_version_3_7_16 = ["pkg-config"]
|
|
+min_sqlite_version_3_7_7 = ["pkg-config"]
|
|
preupdate_hook = []
|
|
session = ["preupdate_hook"]
|
|
sqlcipher = []
|
|
unlock_notify = []
|
|
with-asan = []
|
|
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
|
|
-version = "0.2"
|
|
-optional = true
|