You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
45 lines
1.4 KiB
45 lines
1.4 KiB
--- libsqlite3-sys-0.23.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
+++ libsqlite3-sys-0.23.2/Cargo.toml 2021-12-09T14:49:40.136044+00:00
|
|
@@ -27,7 +27,6 @@
|
|
optional = true
|
|
[build-dependencies.bindgen]
|
|
version = "0.59"
|
|
-features = ["runtime"]
|
|
optional = true
|
|
default-features = false
|
|
|
|
@@ -39,27 +38,16 @@
|
|
version = "0.3.19"
|
|
optional = true
|
|
|
|
-[build-dependencies.vcpkg]
|
|
-version = "0.2"
|
|
-optional = true
|
|
-
|
|
[features]
|
|
-buildtime_bindgen = ["bindgen", "pkg-config", "vcpkg"]
|
|
-bundled = ["cc", "bundled_bindings"]
|
|
-bundled-sqlcipher = ["bundled"]
|
|
-bundled-sqlcipher-vendored-openssl = ["bundled-sqlcipher", "openssl-sys/vendored"]
|
|
-bundled-windows = ["cc", "bundled_bindings"]
|
|
-bundled_bindings = []
|
|
-default = ["min_sqlite_version_3_6_8"]
|
|
+buildtime_bindgen = ["bindgen", "pkg-config"]
|
|
+default = ["min_sqlite_version_3_6_8", "buildtime_bindgen"]
|
|
in_gecko = []
|
|
-min_sqlite_version_3_6_23 = ["pkg-config", "vcpkg"]
|
|
-min_sqlite_version_3_6_8 = ["pkg-config", "vcpkg"]
|
|
-min_sqlite_version_3_7_16 = ["pkg-config", "vcpkg"]
|
|
-min_sqlite_version_3_7_7 = ["pkg-config", "vcpkg"]
|
|
+min_sqlite_version_3_6_23 = ["pkg-config"]
|
|
+min_sqlite_version_3_6_8 = ["pkg-config"]
|
|
+min_sqlite_version_3_7_16 = ["pkg-config"]
|
|
+min_sqlite_version_3_7_7 = ["pkg-config"]
|
|
preupdate_hook = ["buildtime_bindgen"]
|
|
session = ["preupdate_hook", "buildtime_bindgen"]
|
|
sqlcipher = []
|
|
unlock_notify = []
|
|
-wasm32-wasi-vfs = []
|
|
-winsqlite3 = ["min_sqlite_version_3_7_16"]
|
|
with-asan = []
|