You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
43 lines
1.4 KiB
43 lines
1.4 KiB
--- libsqlite3-sys-0.20.1/Cargo.toml 2020-10-07T22:54:16+00:00
|
|
+++ libsqlite3-sys-0.20.1/Cargo.toml 2021-03-05T13:43:46.101915+00:00
|
|
@@ -23,8 +23,7 @@
|
|
license = "MIT"
|
|
repository = "https://github.com/rusqlite/rusqlite"
|
|
[build-dependencies.bindgen]
|
|
-version = "0.55"
|
|
-features = ["runtime"]
|
|
+version = "0.57"
|
|
optional = true
|
|
default-features = false
|
|
|
|
@@ -37,23 +36,15 @@
|
|
optional = true
|
|
|
|
[features]
|
|
-buildtime_bindgen = ["bindgen", "pkg-config", "vcpkg"]
|
|
-bundled = ["cc", "bundled_bindings"]
|
|
-bundled-windows = ["cc", "bundled_bindings"]
|
|
-bundled_bindings = []
|
|
-default = ["min_sqlite_version_3_6_8"]
|
|
+buildtime_bindgen = ["bindgen", "pkg-config"]
|
|
+default = ["min_sqlite_version_3_6_8", "buildtime_bindgen"]
|
|
in_gecko = []
|
|
-min_sqlite_version_3_6_23 = ["pkg-config", "vcpkg"]
|
|
-min_sqlite_version_3_6_8 = ["pkg-config", "vcpkg"]
|
|
-min_sqlite_version_3_7_16 = ["pkg-config", "vcpkg"]
|
|
-min_sqlite_version_3_7_7 = ["pkg-config", "vcpkg"]
|
|
+min_sqlite_version_3_6_23 = ["pkg-config"]
|
|
+min_sqlite_version_3_6_8 = ["pkg-config"]
|
|
+min_sqlite_version_3_7_16 = ["pkg-config"]
|
|
+min_sqlite_version_3_7_7 = ["pkg-config"]
|
|
preupdate_hook = ["buildtime_bindgen"]
|
|
session = ["preupdate_hook", "buildtime_bindgen"]
|
|
sqlcipher = []
|
|
unlock_notify = []
|
|
-wasm32-wasi-vfs = []
|
|
-winsqlite3 = ["min_sqlite_version_3_7_16"]
|
|
with-asan = []
|
|
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
|
|
-version = "0.2"
|
|
-optional = true
|