Update to version 0.17.0+1.8.1; Fixes RHBZ#2292306

epel10 imports/epel10/rust-libgit2-sys-0.17.0-1.el10
Fabio Valentini 4 months ago
parent 74e16e1d47
commit 9de3124606
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -38,3 +38,4 @@
/libgit2-sys-0.15.2+1.6.4.crate
/libgit2-sys-0.16.1+1.7.1.crate
/libgit2-sys-0.16.2+1.7.2.crate
/libgit2-sys-0.17.0+1.8.1.crate

@ -18,7 +18,7 @@ index b497005..4bf1136 100644
-/// Tries to use system libgit2 and emits necessary build script instructions.
-fn try_system_libgit2() -> Result<pkg_config::Library, pkg_config::Error> {
- let mut cfg = pkg_config::Config::new();
- match cfg.range_version("1.7.2".."1.8.0").probe("libgit2") {
- match cfg.range_version("1.8.1".."1.9.0").probe("libgit2") {
- Ok(lib) => {
- for include in &lib.include_paths {
- println!("cargo:root={}", include.display());

@ -1,11 +1,11 @@
--- libgit2-sys-0.16.2+1.7.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ libgit2-sys-0.16.2+1.7.2/Cargo.toml 2024-02-13T15:26:27.947475+00:00
--- libgit2-sys-0.17.0+1.8.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ libgit2-sys-0.17.0+1.8.1/Cargo.toml 2024-10-29T16:56:20.415096+00:00
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "libgit2-sys"
-version = "0.16.2+1.7.2"
+version = "0.16.2"
-version = "0.17.0+1.8.1"
+version = "0.17.0"
authors = [
"Josh Triplett <josh@joshtriplett.org>",
"Alex Crichton <alex@alexcrichton.com>",

@ -1,5 +1,5 @@
--- libgit2-sys-0.16.2+1.7.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ libgit2-sys-0.16.2+1.7.2/Cargo.toml 2024-02-13T15:26:53.261791+00:00
--- libgit2-sys-0.17.0+1.8.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ libgit2-sys-0.17.0+1.8.1/Cargo.toml 2024-10-29T16:56:35.928174+00:00
@@ -27,7 +27,7 @@
"libgit2/tests/*",
]

@ -1,18 +1,18 @@
# Generated by rust2rpm 25
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate libgit2-sys
%global upstream_version 0.16.2+1.7.2
%global upstream_version 0.17.0+1.8.1
Name: rust-libgit2-sys
Version: 0.16.2
Version: 0.17.0
Release: %autorelease
Summary: Native bindings to the libgit2 library
# * libgit2-sys crate: MIT OR Apache-2.0
# * bundled libgit2: GPL-2.0-only WITH GCC-exception-2.0
# * bundled http-parser: MIT
# * bundled llhttp: MIT
# * bundled pcre: BSD-3-Clause
License: (MIT OR Apache-2.0) AND BSD-3-Clause AND GPL-2.0-only WITH GCC-exception-2.0 AND MIT
URL: https://crates.io/crates/libgit2-sys
@ -38,9 +38,9 @@ Native bindings to the libgit2 library.}
Summary: %{summary}
BuildArch: noarch
Provides: bundled(libgit2) = 1.7.2
Provides: bundled(http-parser) = 2.0
Provides: bundled(pcre) = 8.44
Provides: bundled(libgit2) = 1.8.1
Provides: bundled(llhttp) = 9.2.1
Provides: bundled(pcre) = 8.45
%description devel %{_description}
@ -51,7 +51,7 @@ use the "%{crate}" crate.
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%license %{crate_instdir}/libgit2/COPYING
%license %{crate_instdir}/libgit2/deps/http-parser/COPYING
%license %{crate_instdir}/libgit2/deps/llhttp/LICENSE-MIT
%license %{crate_instdir}/libgit2/deps/pcre/LICENCE
%doc %{crate_instdir}/CHANGELOG.md
%{crate_instdir}/

@ -1 +1 @@
SHA512 (libgit2-sys-0.16.2+1.7.2.crate) = 45e23f66e1823c551b1f91d1466d971b05927e591684b35b75047ac5f7d23de889910b662ec403388b88a35dfd19b8ad9787481d36e10949e610aa02fcc35c40
SHA512 (libgit2-sys-0.17.0+1.8.1.crate) = 4c37c30426dbba1d9981d65ee42210ec07e2dae73ce2d18beee17b161eb96de0c7b1696cc8b97fa514eb9fdcb8b853713cd19174fc55f033b6a9c1e25520f75b

Loading…
Cancel
Save