Update to 0.19.1

Signed-off-by: Michel Alexandre Salim <salimma@fedoraproject.org>
epel9
Michel Alexandre Salim 2 years ago
parent 049210e7fa
commit 84809eccf9
No known key found for this signature in database
GPG Key ID: 8B229D2F7CCC04F2

1
.gitignore vendored

@ -8,3 +8,4 @@
/libbpf-rs-0.13.0.crate
/libbpf-rs-0.14.0.crate
/libbpf-rs-0.16.0.crate
/libbpf-rs-0.19.1.crate

@ -1,10 +1,19 @@
--- libbpf-rs-0.16.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ libbpf-rs-0.16.0/Cargo.toml 2022-02-15T19:34:00.245553+00:00
@@ -59,6 +59,7 @@
--- libbpf-rs-0.19.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ libbpf-rs-0.19.1/Cargo.toml 2022-12-09T03:20:15.155206+00:00
@@ -38,7 +38,7 @@
version = "0.5"
[dependencies.strum_macros]
-version = "0.23"
+version = "0.24"
[dependencies.thiserror]
version = "1.0"
@@ -61,6 +61,7 @@
version = "0.5"
[features]
+default = ["novendor"]
novendor = ["libbpf-sys/novendor"]
static = ["libbpf-sys/static"]
[badges.maintenance]
status = "actively-developed"

@ -1,29 +1,23 @@
# Generated by rust2rpm 20
# Generated by rust2rpm 23
%bcond_without check
%global debug_package %{nil}
%global crate libbpf-rs
Name: rust-%{crate}
Version: 0.16.0
Name: rust-libbpf-rs
Version: 0.19.1
Release: %autorelease
Summary: Safe, idiomatic, and opinionated wrapper around libbpf-sys
# Upstream license specification: LGPL-2.1 OR BSD-2-Clause
License: LGPLv2 or BSD
License: LGPL-2.1 OR BSD-2-Clause
URL: https://crates.io/crates/libbpf-rs
Source: %{crates_source}
# Turn on the novendor feature by default
Patch0: libbpf-rs-fix-metadata.diff
# Downgrade libbpf-sys to 0.4.0-2; this patch is meant for Fedora 35 and lower
# where libbpf is still at 0.4.0
Patch1: libbpf-rs-downgrade-libbpf-sys-040.patch
# Downgrade libbpf-sys to 0.5.0-2 (for Fedora 36)
Patch2: libbpf-rs-downgrade-libbpf-sys-050.patch
# Manually created patch for downstream crate metadata changes
# - Turn on the novendor feature by default
# - bump strum_macros dependency to 0.24
Patch: libbpf-rs-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Safe, idiomatic, and opinionated wrapper around libbpf-sys.}
@ -40,9 +34,11 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE LICENSE.BSD-2-Clause LICENSE.LPGL-2.1
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE
%license %{crate_instdir}/LICENSE.BSD-2-Clause
%license %{crate_instdir}/LICENSE.LPGL-2.1
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -54,7 +50,7 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+novendor-devel
Summary: %{summary}
@ -66,20 +62,22 @@ This package contains library source intended for building other packages which
use the "novendor" feature of the "%{crate}" crate.
%files -n %{name}+novendor-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+static-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+static-devel %{_description}
This package contains library source intended for building other packages which
use the "static" feature of the "%{crate}" crate.
%files -n %{name}+static-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%setup -q -n %{crate}-%{version_no_tilde}
%patch0 -p1
%if 0%{?fedora} < 36
%patch1 -p1
%else
%if 0%{?fc36}
%patch2 -p1
%else
sed -i -e 's/version = "0.6.0-1"/version = "0.6.1-2"/' Cargo.toml
%endif
%endif
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
@ -95,6 +93,7 @@ sed -i -e 's/version = "0.6.0-1"/version = "0.6.1-2"/' Cargo.toml
%check
# most of these tests fail, RLIMIT_MEMLOCK does not work in mock
rm tests/test.rs
rm tests/test_tc.rs
%cargo_test
%endif

@ -1 +1 @@
SHA512 (libbpf-rs-0.16.0.crate) = df3f928dbe0e9e7272ada339eec55080e6b32f01f9dc6552b59b02e2f0b46c4a23ae84ffca4e48e4d3d69325d4d0f1d4c3e0442e48922edf42baa482c4dfe102
SHA512 (libbpf-rs-0.19.1.crate) = 44dd68ae101c5aa65bce4a887101fb5f448326fc3cfac645fff960724770a1a1bf7cbab0172467f4b0c3031c7d279385ea3e2c03ca8f85345ef0e55432a0f146

Loading…
Cancel
Save