import #1958352
parent
23553ca823
commit
3c3d211bc8
@ -0,0 +1 @@
|
||||
/libbpf-rs-0.9.1.crate
|
@ -0,0 +1,20 @@
|
||||
--- libbpf-rs-0.9.1/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ libbpf-rs-0.9.1/Cargo.toml 2021-05-10T19:11:36.122837+00:00
|
||||
@@ -25,7 +25,7 @@
|
||||
version = "1.2"
|
||||
|
||||
[dependencies.libbpf-sys]
|
||||
-version = "0.2.0-3"
|
||||
+version = "0.3.0-2"
|
||||
|
||||
[dependencies.nix]
|
||||
version = "0.17"
|
||||
@@ -40,7 +40,7 @@
|
||||
version = "1.0"
|
||||
|
||||
[dependencies.vsprintf]
|
||||
-version = "1.0"
|
||||
+version = "2.0"
|
||||
[dev-dependencies.libc]
|
||||
version = "0.2"
|
||||
|
@ -0,0 +1,82 @@
|
||||
# Generated by rust2rpm 16
|
||||
# Tests don't work in mock at the moment
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate libbpf-rs
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.9.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Safe, idiomatic, and opinionated wrapper around libbpf-sys
|
||||
|
||||
# Upstream license specification: LGPL-2.1 OR BSD-2-Clause
|
||||
License: LGPLv2 or BSD
|
||||
URL: https://crates.io/crates/libbpf-rs
|
||||
Source: %{crates_source}
|
||||
# Fix version pins
|
||||
Patch0: libbpf-rs-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Safe, idiomatic, and opinionated wrapper around libbpf-sys.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE LICENSE.BSD-2-Clause LICENSE.LPGL-2.1
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon May 10 2021 Davide Cavalca <dcavalca@fedoraproject.org> - 0.9.1-1
|
||||
- Update to 0.9.1
|
||||
- Update build requires
|
||||
- Install license files
|
||||
|
||||
* Fri May 07 10:04:18 PDT 2021 Davide Cavalca <dcavalca@fedoraproject.org> - 0.9.0-1
|
||||
- Initial package
|
Loading…
Reference in new issue