You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
294 lines
8.0 KiB
294 lines
8.0 KiB
# Generated by rust2rpm 23
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate lexical-core
|
|
|
|
Name: rust-lexical-core
|
|
Version: 0.7.6
|
|
Release: %autorelease
|
|
Summary: Lexical, to- and from-string conversion routines
|
|
|
|
# Upstream license specification: MIT/Apache-2.0
|
|
License: MIT OR Apache-2.0
|
|
URL: https://crates.io/crates/lexical-core
|
|
Source: %{crates_source}
|
|
# Manually created patch for downstream crate metadata changes
|
|
# * bump approx dev-dependency from 0.4 to 0.5
|
|
# * disable LTO to work around LLVM crashes on ppc64le
|
|
Patch: lexical-core-fix-metadata.diff
|
|
|
|
BuildRequires: rust-packaging >= 21
|
|
|
|
%global _description %{expand:
|
|
Lexical, to- and from-string conversion routines.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-APACHE
|
|
%license %{crate_instdir}/LICENSE-MIT
|
|
%doc %{crate_instdir}/CHANGELOG
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+arrayvec-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+arrayvec-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "arrayvec" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+arrayvec-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+correct-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+correct-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "correct" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+correct-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+dtoa-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+dtoa-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "dtoa" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+dtoa-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+format-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+format-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "format" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+format-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+grisu3-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+grisu3-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "grisu3" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+grisu3-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+libm-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+libm-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "libm" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+libm-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+noinline-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+noinline-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "noinline" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+noinline-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+property_tests-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+property_tests-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "property_tests" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+property_tests-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+proptest-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+proptest-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "proptest" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+proptest-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+quickcheck-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+quickcheck-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "quickcheck" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+quickcheck-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+radix-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+radix-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "radix" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+radix-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+rounding-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+rounding-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "rounding" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+rounding-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+ryu-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+ryu-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "ryu" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+ryu-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+static_assertions-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+static_assertions-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "static_assertions" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+static_assertions-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+std-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+std-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "std" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+std-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+table-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+table-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "table" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+table-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+trim_floats-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+trim_floats-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "trim_floats" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+trim_floats-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+unchecked_index-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+unchecked_index-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "unchecked_index" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+unchecked_index-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
# remove executable bit from all files
|
|
find . -type f -executable -exec chmod -x {} +
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|