You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-konst_macro_rules/SPECS/rust-konst_macro_rules.spec

187 lines
5.2 KiB

## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate konst_macro_rules
Name: rust-konst_macro_rules
Version: 0.2.19
Release: %autorelease
Summary: Implementation detail of the konst crate
License: Zlib
URL: https://crates.io/crates/konst_macro_rules
Source: %{crates_source}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Implementation detail of the konst crate.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-ZLIB.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+deref_raw_in_fn-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+deref_raw_in_fn-devel %{_description}
This package contains library source intended for building other packages which
use the "deref_raw_in_fn" feature of the "%{crate}" crate.
%files -n %{name}+deref_raw_in_fn-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+mut_refs-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+mut_refs-devel %{_description}
This package contains library source intended for building other packages which
use the "mut_refs" feature of the "%{crate}" crate.
%files -n %{name}+mut_refs-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nightly_mut_refs-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nightly_mut_refs-devel %{_description}
This package contains library source intended for building other packages which
use the "nightly_mut_refs" feature of the "%{crate}" crate.
%files -n %{name}+nightly_mut_refs-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rust_1_51-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rust_1_51-devel %{_description}
This package contains library source intended for building other packages which
use the "rust_1_51" feature of the "%{crate}" crate.
%files -n %{name}+rust_1_51-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rust_1_55-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rust_1_55-devel %{_description}
This package contains library source intended for building other packages which
use the "rust_1_55" feature of the "%{crate}" crate.
%files -n %{name}+rust_1_55-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rust_1_56-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rust_1_56-devel %{_description}
This package contains library source intended for building other packages which
use the "rust_1_56" feature of the "%{crate}" crate.
%files -n %{name}+rust_1_56-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rust_1_57-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rust_1_57-devel %{_description}
This package contains library source intended for building other packages which
use the "rust_1_57" feature of the "%{crate}" crate.
%files -n %{name}+rust_1_57-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rust_1_61-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rust_1_61-devel %{_description}
This package contains library source intended for building other packages which
use the "rust_1_61" feature of the "%{crate}" crate.
%files -n %{name}+rust_1_61-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.2.19-1
- Rebuilt for MSVSphere 9.3
* Sun Aug 06 2023 Fabio Valentini <decathorpe@gmail.com> - 0.2.19-1
- Update to version 0.2.19; Fixes RHBZ#2133254
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.14-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.14-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Tue Jul 26 2022 Davide Cavalca <dcavalca@fedoraproject.org> - 0.2.14-1
- Initial import; Fixes: RHBZ#2105874