parent
7864706ba2
commit
2c14b4a1a7
@ -0,0 +1 @@
|
||||
/jobserver-0.1.9.crate
|
@ -0,0 +1,8 @@
|
||||
--- jobserver-0.1.9/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ jobserver-0.1.9/Cargo.toml 2018-01-13T17:16:25.272568+01:00
|
||||
@@ -58,5 +58,3 @@
|
||||
version = "0.1"
|
||||
[target."cfg(unix)".dependencies.libc]
|
||||
version = "0.2"
|
||||
-[target."cfg(windows)".dependencies.rand]
|
||||
-version = "0.3"
|
@ -0,0 +1,68 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate jobserver
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.1.9
|
||||
Release: 1%{?dist}
|
||||
Summary: Implementation of the GNU make jobserver for Rust
|
||||
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/jobserver
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * No windows
|
||||
Patch0: jobserver-0.1.9-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
# [dependencies]
|
||||
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
|
||||
%if %{with check}
|
||||
# [dev-dependencies]
|
||||
BuildRequires: (crate(futures) >= 0.1.0 with crate(futures) < 0.2.0)
|
||||
BuildRequires: (crate(num_cpus) >= 1.0.0 with crate(num_cpus) < 2.0.0)
|
||||
BuildRequires: (crate(tempdir) >= 0.3.0 with crate(tempdir) < 0.4.0)
|
||||
BuildRequires: (crate(tokio-core) >= 0.1.0 with crate(tokio-core) < 0.2.0)
|
||||
BuildRequires: (crate(tokio-process) >= 0.1.0 with crate(tokio-process) < 0.2.0)
|
||||
%endif
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
An implementation of the GNU make jobserver for Rust.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license LICENSE-MIT LICENSE-APACHE
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
|
||||
%changelog
|
||||
* Sat Jan 13 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.9-1
|
||||
- Initial package
|
Loading…
Reference in new issue