You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
149 lines
4.3 KiB
149 lines
4.3 KiB
## START: Set by rpmautospec
|
|
## (rpmautospec version 0.7.3)
|
|
## RPMAUTOSPEC: autorelease, autochangelog
|
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
|
release_number = 2;
|
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
|
print(release_number + base_release_number - 1);
|
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
|
## END: Set by rpmautospec
|
|
|
|
# Generated by rust2rpm 27
|
|
%bcond check 1
|
|
%global debug_package %{nil}
|
|
|
|
%global crate jiter
|
|
|
|
Name: rust-jiter
|
|
Version: 0.7.1
|
|
Release: %autorelease
|
|
Summary: Fast Iterable JSON parser
|
|
|
|
License: MIT
|
|
URL: https://crates.io/crates/jiter
|
|
Source: %{crates_source}
|
|
# Manually created patch for downstream crate metadata changes
|
|
# * Update to a current version of lexical-parse-float:
|
|
# https://github.com/pydantic/jiter/pull/182
|
|
Patch: jiter-fix-metadata.diff
|
|
|
|
BuildRequires: cargo-rpm-macros >= 24
|
|
BuildRequires: tomcli
|
|
|
|
%global _description %{expand:
|
|
Fast Iterable JSON parser.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+num-bigint-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+num-bigint-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "num-bigint" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+num-bigint-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+python-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+python-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "python" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+python-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version} -p1
|
|
%cargo_prep
|
|
# Omit benchmark-only dependencies.
|
|
tomcli-set Cargo.toml del dev-dependencies.bencher
|
|
tomcli-set Cargo.toml del dev-dependencies.codspeed-bencher-compat
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
## START: Generated by rpmautospec
|
|
* Sun Jan 05 2025 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.7.1-2
|
|
- Rebuilt for MSVSphere 10
|
|
|
|
* Fri Dec 27 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.7.1-2
|
|
- Patch for rust-lexical-parse-float 1.0.5
|
|
|
|
* Sat Nov 16 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.7.1-1
|
|
- Update to 0.7.1 (close RHBZ#2316974)
|
|
|
|
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
|
|
|
* Tue Jun 25 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.5.0-1
|
|
- Update to 0.5.0 (close RHBZ#2294053)
|
|
|
|
* Wed Jun 12 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.4.2-1
|
|
- Update to 0.4.2 (close RHBZ#2291469)
|
|
|
|
* Wed Jun 05 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.4.1-1
|
|
- Update to 0.4.1 (close RHBZ#2277955)
|
|
- Reduce manual editing of the spec file after running rust2rpm
|
|
- Reduce unnecessary (benchmark-only) build dependencies
|
|
|
|
* Sat Apr 13 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.2.1-1
|
|
- Update to 0.2.1 (close RHBZ#2269166)
|
|
|
|
* Tue Feb 06 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.0.6-2
|
|
- Combine the two patches
|
|
|
|
* Sun Jan 28 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.0.6-1
|
|
- Update to 0.0.6. Closes rhbz#2258869.
|
|
|
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.0.4-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
|
|
|
* Wed Dec 20 2023 Maxwell G <maxwell@gtmx.me> - 0.0.4-1
|
|
- Initial package. Closes rhbz#2254855.
|
|
## END: Generated by rpmautospec
|