You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
67 lines
1.6 KiB
67 lines
1.6 KiB
--- jiff-0.1.19/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
+++ jiff-0.1.19/Cargo.toml 2025-01-02T17:43:43.766886+00:00
|
|
@@ -137,7 +137,6 @@
|
|
[features]
|
|
alloc = [
|
|
"serde?/alloc",
|
|
- "portable-atomic-util/alloc",
|
|
]
|
|
default = [
|
|
"std",
|
|
@@ -146,8 +145,6 @@
|
|
"tzdb-zoneinfo",
|
|
]
|
|
js = [
|
|
- "dep:wasm-bindgen",
|
|
- "dep:js-sys",
|
|
]
|
|
logging = ["dep:log"]
|
|
serde = ["dep:serde"]
|
|
@@ -158,46 +155,16 @@
|
|
]
|
|
tz-system = [
|
|
"std",
|
|
- "dep:windows-sys",
|
|
]
|
|
tzdb-bundle-always = [
|
|
"dep:jiff-tzdb",
|
|
"alloc",
|
|
]
|
|
tzdb-bundle-platform = [
|
|
- "dep:jiff-tzdb-platform",
|
|
"alloc",
|
|
]
|
|
tzdb-zoneinfo = ["std"]
|
|
|
|
-[target.'cfg(all(any(target_arch = "wasm32", target_arch = "wasm64"), target_os = "unknown"))'.dependencies.js-sys]
|
|
-version = "0.3.50"
|
|
-optional = true
|
|
-
|
|
-[target.'cfg(all(any(target_arch = "wasm32", target_arch = "wasm64"), target_os = "unknown"))'.dependencies.wasm-bindgen]
|
|
-version = "0.2.70"
|
|
-optional = true
|
|
-
|
|
-[target.'cfg(any(windows, target_family = "wasm"))'.dependencies.jiff-tzdb-platform]
|
|
-version = "0.1.1"
|
|
-optional = true
|
|
-
|
|
[target.'cfg(not(target_family = "wasm"))'.dev-dependencies.hifitime]
|
|
version = "3.9.0"
|
|
|
|
-[target.'cfg(not(target_has_atomic = "ptr"))'.dependencies.portable-atomic]
|
|
-version = "1.10.0"
|
|
-default-features = false
|
|
-
|
|
-[target.'cfg(not(target_has_atomic = "ptr"))'.dependencies.portable-atomic-util]
|
|
-version = "0.2.4"
|
|
-default-features = false
|
|
-
|
|
-[target."cfg(windows)".dependencies.windows-sys]
|
|
-version = ">=0.52.0, <=0.59.*"
|
|
-features = [
|
|
- "Win32_Foundation",
|
|
- "Win32_System_Time",
|
|
-]
|
|
-optional = true
|
|
-default-features = false
|