You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-jiff/jiff-fix-metadata-auto.diff

50 lines
1.2 KiB

--- jiff-0.1.12/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.12/Cargo.toml 2024-09-02T12:07:13.750837+00:00
@@ -126,46 +126,22 @@
"tzdb-zoneinfo",
]
js = [
- "dep:wasm-bindgen",
- "dep:js-sys",
]
logging = ["dep:log"]
serde = ["dep:serde"]
std = ["alloc"]
tz-system = [
"std",
- "dep:windows-sys",
]
tzdb-bundle-always = [
"dep:jiff-tzdb",
"alloc",
]
tzdb-bundle-platform = [
- "dep:jiff-tzdb-platform",
"alloc",
]
tzdb-zoneinfo = ["std"]
-[target.'cfg(all(any(target_arch = "wasm32", target_arch = "wasm64"), target_os = "unknown"))'.dependencies.js-sys]
-version = "0.3.50"
-optional = true
-
-[target.'cfg(all(any(target_arch = "wasm32", target_arch = "wasm64"), target_os = "unknown"))'.dependencies.wasm-bindgen]
-version = "0.2.70"
-optional = true
-
-[target.'cfg(any(windows, target_family = "wasm"))'.dependencies.jiff-tzdb-platform]
-version = "0.1.0"
-optional = true
-
[target.'cfg(not(target_family = "wasm"))'.dev-dependencies.hifitime]
version = "3.9.0"
-[target."cfg(windows)".dependencies.windows-sys]
-version = ">=0.52.0, <=0.59.*"
-features = [
- "Win32_Foundation",
- "Win32_System_Time",
-]
-optional = true
-default-features = false