Update to 0.1.14 (close RHBZ#2323154)

epel10
Benjamin A. Beasley 3 months ago
parent 58ad727144
commit 8e6e73fa4b

1
.gitignore vendored

@ -2,3 +2,4 @@
/jiff-0.1.10.crate
/jiff-0.1.12.crate
/jiff-0.1.13.crate
/jiff-0.1.14.crate

@ -0,0 +1,25 @@
From c3b537015e5bd9ac571cac96a3967a6d9ea48989 Mon Sep 17 00:00:00 2001
From: "Benjamin A. Beasley" <code@musicinmybrain.net>
Date: Mon, 11 Nov 2024 10:53:45 -0500
Subject: [PATCH] Downstream-only: Omit doctests that require icu
---
COMPARE.md | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/COMPARE.md b/COMPARE.md
index 6ebf29c..8bdab4f 100644
--- a/COMPARE.md
+++ b/COMPARE.md
@@ -1129,7 +1129,7 @@ timestamp or duration type.
`icu` can be used to complement `jiff` when localized date formatting or
calendar conversions are required:
-```rust
+```ignore
use icu::{
calendar::{japanese::Japanese, DateTime},
datetime::TypedDateTimeFormatter,
--
2.47.0

@ -1,6 +1,6 @@
--- jiff-0.1.13/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.13/Cargo.toml 2024-09-19T11:24:01.514919+00:00
@@ -126,46 +126,22 @@
--- jiff-0.1.14/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.14/Cargo.toml 2024-11-11T15:54:54.361809+00:00
@@ -131,46 +131,22 @@
"tzdb-zoneinfo",
]
js = [

@ -1,6 +1,6 @@
--- jiff-0.1.13/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.13/Cargo.toml 2024-09-19T11:24:03.829950+00:00
@@ -142,6 +142,3 @@
--- jiff-0.1.14/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.14/Cargo.toml 2024-11-11T15:54:56.392835+00:00
@@ -147,6 +147,3 @@
]
tzdb-zoneinfo = ["std"]

@ -5,7 +5,7 @@
%global crate jiff
Name: rust-jiff
Version: 0.1.13
Version: 0.1.14
Release: %autorelease
Summary: Date-time library that encourages you to jump into the pit of success
@ -20,6 +20,8 @@ Patch: jiff-fix-metadata.diff
# * Downstream-only: Omit doctests that require hifitime. It is not worth
# packaging it solely for a couple of tiny examples.
Patch10: 0001-Downstream-only-Omit-doctests-that-require-hifitime.patch
# * Downstream-only: Omit doctests that require icu.
Patch11: 0001-Downstream-only-Omit-doctests-that-require-icu.patch
# * EPEL9: Ignore doctests that require very recent Rust compilers
# * In this crate, doctests and examples (but not the lib and integration tests)
# are allowed to use Rust features from versions newer than the MSRV. Its
@ -162,6 +164,8 @@ use the "tzdb-zoneinfo" feature of the "%{crate}" crate.
%if 0%{?el9}
%patch -P 1009 -p1
%endif
# We do not yet have a rust-icu package (although one would be desirable)
tomcli set Cargo.toml del dev-dependencies.icu
%cargo_prep
# Exclude test and debug scripts that would BuildRequire sh or bash
tomcli set Cargo.toml append package.exclude test test-wasm 'scripts/*'

@ -31,6 +31,15 @@ comments = [
""",
]
[[package.extra-patches]]
number = 11
file = "0001-Downstream-only-Omit-doctests-that-require-icu.patch"
comments = [
"""\
Downstream-only: Omit doctests that require icu.\
""",
]
[[package.extra-patches]]
number = 1009
file = "0001-EPEL9-Ignore-doctests-that-require-very-recent-Rust-.patch"
@ -63,6 +72,8 @@ pre = [
# to use "%patch -P <N>" instead.
"%patch -P 1009 -p1",
"%endif",
"# We do not yet have a rust-icu package (although one would be desirable)",
"tomcli set Cargo.toml del dev-dependencies.icu",
]
post = [
"# Exclude test and debug scripts that would BuildRequire sh or bash",

@ -1 +1 @@
SHA512 (jiff-0.1.13.crate) = 70025484872505d2ea50e59c463343280cf2ef5041a1a166f499802022d8ebd1f7ad2fc6ed569688a7bea097988941f21ccb1bae690c3924a6828381fe05c35d
SHA512 (jiff-0.1.14.crate) = 3f1d403e4a6393bcb84b93d4aa0b876de83056fa7dd145b61da611b5436a7dd6ecd1d1681c2eec8c61406c9f4f5cca7cc3000391c9fbeac2f81d7666fdea0d0e

Loading…
Cancel
Save