Update to 0.1.23 (close RHBZ#2337484)

epel10
Benjamin A. Beasley 3 weeks ago
parent 46d74f2d5a
commit 7503c6f733

1
.gitignore vendored

@ -10,3 +10,4 @@
/jiff-0.1.19.crate
/jiff-0.1.20.crate
/jiff-0.1.21.crate
/jiff-0.1.23.crate

@ -1,6 +1,6 @@
--- jiff-0.1.21/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.21/Cargo.toml 2025-01-05T18:56:41.617601+00:00
@@ -137,7 +137,6 @@
--- jiff-0.1.23/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.23/Cargo.toml 2025-01-14T02:33:55.951394+00:00
@@ -141,7 +141,6 @@
[features]
alloc = [
"serde?/alloc",
@ -8,8 +8,8 @@
]
default = [
"std",
@@ -146,8 +145,6 @@
"tzdb-zoneinfo",
@@ -151,8 +150,6 @@
"tzdb-concatenated",
]
js = [
- "dep:wasm-bindgen",
@ -17,7 +17,7 @@
]
logging = ["dep:log"]
serde = ["dep:serde"]
@@ -158,46 +155,16 @@
@@ -163,47 +160,17 @@
]
tz-system = [
"std",
@ -31,6 +31,7 @@
- "dep:jiff-tzdb-platform",
"alloc",
]
tzdb-concatenated = ["std"]
tzdb-zoneinfo = ["std"]
-[target.'cfg(all(any(target_arch = "wasm32", target_arch = "wasm64"), target_os = "unknown"))'.dependencies.js-sys]

@ -1,6 +1,6 @@
--- jiff-0.1.21/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.21/Cargo.toml 2025-01-05T18:56:41.619601+00:00
@@ -114,9 +114,6 @@
--- jiff-0.1.23/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.23/Cargo.toml 2025-01-14T02:33:55.952394+00:00
@@ -118,9 +118,6 @@
[dev-dependencies.serde_json]
version = "1.0.117"
@ -10,8 +10,8 @@
[dev-dependencies.tabwriter]
version = "1.4.0"
@@ -165,6 +162,3 @@
]
@@ -171,6 +168,3 @@
tzdb-concatenated = ["std"]
tzdb-zoneinfo = ["std"]
-[target.'cfg(not(target_family = "wasm"))'.dev-dependencies.hifitime]

@ -1,11 +1,14 @@
# Generated by rust2rpm 27
%bcond check 1
# * Since 0.1.22, src/tz/snapshots/ and src/tz/testdata/ are no longer included
# in the crate, so it is not feasible to run the tests without a separate
# source archive.
%bcond check 0
%global debug_package %{nil}
%global crate jiff
Name: rust-jiff
Version: 0.1.21
Version: 0.1.23
Release: %autorelease
Summary: Date-time library that encourages you to jump into the pit of success
@ -147,6 +150,18 @@ use the "tzdb-bundle-platform" feature of the "%{crate}" crate.
%files -n %{name}+tzdb-bundle-platform-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tzdb-concatenated-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tzdb-concatenated-devel %{_description}
This package contains library source intended for building other packages which
use the "tzdb-concatenated" feature of the "%{crate}" crate.
%files -n %{name}+tzdb-concatenated-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tzdb-zoneinfo-devel
Summary: %{summary}
BuildArch: noarch
@ -171,8 +186,6 @@ use the "tzdb-zoneinfo" feature of the "%{crate}" crate.
# We do not yet have a rust-icu package (although one would be desirable)
tomcli set Cargo.toml del dev-dependencies.icu
%cargo_prep
# Exclude test and debug scripts that would BuildRequire sh or bash
tomcli set Cargo.toml append package.exclude test test-wasm 'scripts/*'
%generate_buildrequires
%cargo_generate_buildrequires -f serde

@ -88,7 +88,14 @@ pre = [
"# We do not yet have a rust-icu package (although one would be desirable)",
"tomcli set Cargo.toml del dev-dependencies.icu",
]
post = [
"# Exclude test and debug scripts that would BuildRequire sh or bash",
"tomcli set Cargo.toml append package.exclude test test-wasm 'scripts/*'",
[tests]
comments = [
"""\
Since 0.1.22, src/tz/snapshots/ and src/tz/testdata/ are no longer included \
in the crate, so it is not feasible to run the tests without a separate \
source archive.\
""",
]
run = ["none"]

@ -1 +1 @@
SHA512 (jiff-0.1.21.crate) = f78e3ef0023d8dfebd50f3651bfc1ebe5453d0f99d3a3581648dd2e3194253e8f864da4b8c1d1871516c71e92fe8f47f4cbdbde52db9cebc52d38be177b0b4e9
SHA512 (jiff-0.1.23.crate) = 9faac5b8f560023b68d6e0fecc2cab898deb9bee816af47994fcb9212cb49a5513fcff5031fe493b939ceb6ef907852764b78d5395d7adfc6adcba3f0191d476

Loading…
Cancel
Save