Update to 0.1.28 (close RHBZ#2342297)

epel10 imports/epel10/rust-jiff-0.1.28-1.el10
Benjamin A. Beasley 2 weeks ago
parent 4bcb74b8c3
commit 168334125f

2
.gitignore vendored

@ -18,3 +18,5 @@
/jiff-0.1.26.tar.gz
/jiff-0.1.27.crate
/jiff-0.1.27.tar.gz
/jiff-0.1.28.crate
/jiff-0.1.28.tar.gz

@ -1,109 +0,0 @@
From cc1d9dff0b581f8a33268b3d2495b60d2b770d4c Mon Sep 17 00:00:00 2001
From: "Benjamin A. Beasley" <code@musicinmybrain.net>
Date: Thu, 26 Dec 2024 18:51:44 -0500
Subject: [PATCH] Downstream-only: omit tests that require serde_yml
---
src/civil/date.rs | 2 ++
src/civil/datetime.rs | 2 ++
src/civil/time.rs | 2 ++
src/signed_duration.rs | 2 ++
src/span.rs | 2 ++
src/timestamp.rs | 2 ++
src/zoned.rs | 2 ++
7 files changed, 14 insertions(+)
diff --git a/src/civil/date.rs b/src/civil/date.rs
index 214c988..9a35c0b 100644
--- a/src/civil/date.rs
+++ b/src/civil/date.rs
@@ -4009,6 +4009,8 @@ mod tests {
}
}
+ // Downstream-only: omit tests that require serde_yml
+ #[cfg(any())]
/// # `serde` deserializer compatibility test
///
/// Serde YAML used to be unable to deserialize `jiff` types,
diff --git a/src/civil/datetime.rs b/src/civil/datetime.rs
index e1249b3..ea14006 100644
--- a/src/civil/datetime.rs
+++ b/src/civil/datetime.rs
@@ -4280,6 +4280,8 @@ mod tests {
}
}
+ // Downstream-only: omit tests that require serde_yml
+ #[cfg(any())]
/// # `serde` deserializer compatibility test
///
/// Serde YAML used to be unable to deserialize `jiff` types,
diff --git a/src/civil/time.rs b/src/civil/time.rs
index c7d252b..dc8ca9f 100644
--- a/src/civil/time.rs
+++ b/src/civil/time.rs
@@ -3363,6 +3363,8 @@ mod tests {
assert_eq!(got, expected);
}
+ // Downstream-only: omit tests that require serde_yml
+ #[cfg(any())]
/// # `serde` deserializer compatibility test
///
/// Serde YAML used to be unable to deserialize `jiff` types,
diff --git a/src/signed_duration.rs b/src/signed_duration.rs
index f002d7c..8e8a42b 100644
--- a/src/signed_duration.rs
+++ b/src/signed_duration.rs
@@ -2255,6 +2255,8 @@ mod tests {
assert_eq!(None, add((i64::MIN, -1), (0, -999_999_999)));
}
+ // Downstream-only: omit tests that require serde_yml
+ #[cfg(any())]
/// # `serde` deserializer compatibility test
///
/// Serde YAML used to be unable to deserialize `jiff` types,
diff --git a/src/span.rs b/src/span.rs
index 9a00d04..ffad9d2 100644
--- a/src/span.rs
+++ b/src/span.rs
@@ -6464,6 +6464,8 @@ mod tests {
}
}
+ // Downstream-only: omit tests that require serde_yml
+ #[cfg(any())]
/// # `serde` deserializer compatibility test
///
/// Serde YAML used to be unable to deserialize `jiff` types,
diff --git a/src/timestamp.rs b/src/timestamp.rs
index 88ae03b..5cdd65b 100644
--- a/src/timestamp.rs
+++ b/src/timestamp.rs
@@ -3700,6 +3700,8 @@ mod tests {
}
}
+ // Downstream-only: omit tests that require serde_yml
+ #[cfg(any())]
/// A `serde` deserializer compatibility test.
///
/// Serde YAML used to be unable to deserialize `jiff` types,
diff --git a/src/zoned.rs b/src/zoned.rs
index 70e88e7..80e9b26 100644
--- a/src/zoned.rs
+++ b/src/zoned.rs
@@ -5264,6 +5264,8 @@ mod tests {
}
}
+ // Downstream-only: omit tests that require serde_yml
+ #[cfg(any())]
/// A `serde` deserializer compatibility test.
///
/// Serde YAML used to be unable to deserialize `jiff` types,
--
2.47.1

@ -1,5 +1,5 @@
--- jiff-0.1.27/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.27/Cargo.toml 2025-01-26T16:01:04.009091+00:00
--- jiff-0.1.28/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.28/Cargo.toml 2025-01-28T22:28:45.176170+00:00
@@ -60,7 +60,6 @@
[features]
alloc = [

@ -1,16 +1,6 @@
--- jiff-0.1.27/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.27/Cargo.toml 2025-01-26T16:01:04.011091+00:00
@@ -147,9 +147,6 @@
[dev-dependencies.serde_json]
version = "1.0.117"
-[dev-dependencies.serde_yml]
-version = "0.0.12"
-
[dev-dependencies.tabwriter]
version = "1.4.0"
@@ -167,9 +164,6 @@
--- jiff-0.1.28/Cargo.toml 1970-01-01T00:00:01+00:00
+++ jiff-0.1.28/Cargo.toml 2025-01-28T22:29:05.850435+00:00
@@ -167,9 +167,6 @@
[dev-dependencies.walkdir]
version = "2.5.0"

@ -5,7 +5,7 @@
%global crate jiff
Name: rust-jiff
Version: 0.1.27
Version: 0.1.28
Release: %autorelease
Summary: Date-time library that encourages you to jump into the pit of success
@ -23,16 +23,12 @@ Source10: https://github.com/BurntSushi/jiff/archive/%{version}/jiff-%{ver
Patch: jiff-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * Drop dev-dependency hifitime: not packaged, and only for doctests
# * Drop dev-dependency serde_yml: not packaged; we have patched out the tests
# that require it
Patch: jiff-fix-metadata.diff
# * Downstream-only: Omit doctests that require hifitime. It is not worth
# packaging it solely for a couple of tiny examples.
Patch10: 0001-Downstream-only-Omit-doctests-that-require-hifitime.patch
# * Downstream-only: Omit doctests that require icu.
Patch11: 0001-Downstream-only-Omit-doctests-that-require-icu.patch
# * Downstream-only: Omit tests that require serde_yml.
Patch12: 0001-Downstream-only-omit-tests-that-require-serde_yml.patch
# * EPEL9: Ignore doctests that require very recent Rust compilers
# * In this crate, doctests and examples (but not the lib and integration tests)
# are allowed to use Rust features from versions newer than the MSRV. Its

@ -19,10 +19,6 @@ cargo-toml-patch-comments = [
# an unconditional dependency, but given it is
# target.'cfg(not(target_family = "wasm"))', manual patching is easier.
"Drop dev-dependency hifitime: not packaged, and only for doctests",
"""\
Drop dev-dependency serde_yml: not packaged; we have patched out the tests \
that require it\
""",
]
[[package.extra-sources]]
@ -58,15 +54,6 @@ comments = [
""",
]
[[package.extra-patches]]
number = 12
file = "0001-Downstream-only-omit-tests-that-require-serde_yml.patch"
comments = [
"""\
Downstream-only: Omit tests that require serde_yml.\
""",
]
[[package.extra-patches]]
number = 1009
file = "0001-EPEL9-Ignore-doctests-that-require-very-recent-Rust-.patch"

@ -1,2 +1,2 @@
SHA512 (jiff-0.1.27.crate) = a05eb5f45ede055c7ccb029288aff49e2845a32f1a2da390a05bb3253a0629a321e8eef684c7a620f8050314890b0f9b55edbb7e33ffd99a1ecb04c0438a3066
SHA512 (jiff-0.1.27.tar.gz) = 1952fab350b61985c97f650b8454e41824f01f8c4b904b1d78eefae0f95363b0afbdf887d5adf07e9f5e150d1b0e73c585aeb029a5e598f91a05bcda0c12e7ee
SHA512 (jiff-0.1.28.crate) = 66952f5fe970205325659050f55b04c250ad02b8782debcd870d1e74eb76f3fd2db8149d485640ae0b34c70ff4810ba50625bc6d296b55f88bfd16e5339bd513
SHA512 (jiff-0.1.28.tar.gz) = b4e94054363cf4f5c39951c2706464015c57d89fff9fa90f8b6c2f260c89cafa561efe589a652f1d8ba16fe42976fdf49d04950cebef69558ef3caa1a61816fb

Loading…
Cancel
Save