You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-itertools0.11/rust-itertools0.11.spec

98 lines
2.4 KiB

# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate itertools
Name: rust-itertools0.11
Version: 0.11.0
Release: %autorelease
Summary: Extra iterator adaptors, iterator methods, free functions, and macros
License: MIT OR Apache-2.0
URL: https://crates.io/crates/itertools
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
Patch: itertools-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Extra iterator adaptors, iterator methods, free functions, and macros.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+use_alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+use_alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "use_alloc" feature of the "%{crate}" crate.
%files -n %{name}+use_alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+use_std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+use_std-devel %{_description}
This package contains library source intended for building other packages which
use the "use_std" feature of the "%{crate}" crate.
%files -n %{name}+use_std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog