parent
b72f6d02fe
commit
94e7ccd587
@ -0,0 +1 @@
|
||||
/itertools-0.11.0.crate
|
@ -0,0 +1,12 @@
|
||||
--- itertools-0.11.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ itertools-0.11.0/Cargo.toml 2023-12-12T11:48:13.467837+00:00
|
||||
@@ -76,9 +76,6 @@
|
||||
version = "1.0"
|
||||
default-features = false
|
||||
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.4.0"
|
||||
-
|
||||
[dev-dependencies.paste]
|
||||
version = "1.0.0"
|
||||
|
@ -0,0 +1,97 @@
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate itertools
|
||||
|
||||
Name: rust-itertools0.11
|
||||
Version: 0.11.0
|
||||
Release: %autorelease
|
||||
Summary: Extra iterator adaptors, iterator methods, free functions, and macros
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/itertools
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
|
||||
Patch: itertools-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Extra iterator adaptors, iterator methods, free functions, and macros.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+use_alloc-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+use_alloc-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "use_alloc" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+use_alloc-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+use_std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+use_std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "use_std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+use_std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue