import rust-io-lifetimes1-1.0.11-1.el9

i9ce changed/i9ce/rust-io-lifetimes1-1.0.11-1.el9
Arkady L. Shane 1 year ago
commit 7220dcc57e
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

Binary file not shown.

@ -0,0 +1,30 @@
--- io-lifetimes-1.0.11/Cargo.toml 1970-01-01T00:00:01+00:00
+++ io-lifetimes-1.0.11/Cargo.toml 2023-11-05T00:09:00.236364+00:00
@@ -42,8 +42,6 @@
[features]
close = [
"libc",
- "hermit-abi",
- "windows-sys",
]
default = ["close"]
@@ -82,18 +80,3 @@
version = "0.2.96"
optional = true
-[target."cfg(target_os = \"hermit\")".dependencies.hermit-abi]
-version = "0.3"
-optional = true
-
-[target."cfg(windows)".dependencies.windows-sys]
-version = "0.48.0"
-features = [
- "Win32_Foundation",
- "Win32_Storage_FileSystem",
- "Win32_Networking_WinSock",
- "Win32_Security",
- "Win32_System_IO",
- "Win32_System_Threading",
-]
-optional = true

@ -0,0 +1,185 @@
## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate io-lifetimes
Name: rust-io-lifetimes1
Version: 1.0.11
Release: %autorelease
Summary: Low-level I/O ownership and borrowing library
License: Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
URL: https://crates.io/crates/io-lifetimes
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: io-lifetimes-fix-metadata-auto.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A low-level I/O ownership and borrowing library.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/COPYRIGHT
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-Apache-2.0_WITH_LLVM-exception
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CODE_OF_CONDUCT.md
%doc %{crate_instdir}/ORG_CODE_OF_CONDUCT.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+async-std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+async-std-devel %{_description}
This package contains library source intended for building other packages which
use the "async-std" feature of the "%{crate}" crate.
%files -n %{name}+async-std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+close-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+close-devel %{_description}
This package contains library source intended for building other packages which
use the "close" feature of the "%{crate}" crate.
%files -n %{name}+close-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fs-err-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fs-err-devel %{_description}
This package contains library source intended for building other packages which
use the "fs-err" feature of the "%{crate}" crate.
%files -n %{name}+fs-err-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+libc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+libc-devel %{_description}
This package contains library source intended for building other packages which
use the "libc" feature of the "%{crate}" crate.
%files -n %{name}+libc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+mio-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+mio-devel %{_description}
This package contains library source intended for building other packages which
use the "mio" feature of the "%{crate}" crate.
%files -n %{name}+mio-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+os_pipe-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+os_pipe-devel %{_description}
This package contains library source intended for building other packages which
use the "os_pipe" feature of the "%{crate}" crate.
%files -n %{name}+os_pipe-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+socket2-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+socket2-devel %{_description}
This package contains library source intended for building other packages which
use the "socket2" feature of the "%{crate}" crate.
%files -n %{name}+socket2-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tokio-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tokio-devel %{_description}
This package contains library source intended for building other packages which
use the "tokio" feature of the "%{crate}" crate.
%files -n %{name}+tokio-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.0.11-1
- Rebuilt for MSVSphere 9.3
* Thu Nov 09 2023 Fabio Valentini <decathorpe@gmail.com> - 1.0.11-1
- Initial import (io-lifetimes 1 compat package)
Loading…
Cancel
Save