You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
134 lines
3.9 KiB
134 lines
3.9 KiB
## START: Set by rpmautospec
|
|
## (rpmautospec version 0.3.5)
|
|
## RPMAUTOSPEC: autorelease, autochangelog
|
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
|
release_number = 1;
|
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
|
print(release_number + base_release_number - 1);
|
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
|
## END: Set by rpmautospec
|
|
|
|
# Generated by rust2rpm 24
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate indoc
|
|
|
|
Name: rust-indoc
|
|
Version: 2.0.4
|
|
Release: %autorelease
|
|
Summary: Indented document literals
|
|
|
|
License: MIT OR Apache-2.0
|
|
URL: https://crates.io/crates/indoc
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: rust-packaging >= 21
|
|
|
|
%global _description %{expand:
|
|
Indented document literals.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-APACHE
|
|
%license %{crate_instdir}/LICENSE-MIT
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
* Thu Jan 11 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 2.0.4-1
|
|
- Rebuilt for MSVSphere 9.3
|
|
|
|
* Mon Sep 18 2023 Fabio Valentini <decathorpe@gmail.com> - 2.0.4-1
|
|
- Update to version 2.0.4; Fixes RHBZ#2239263
|
|
|
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.3-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
|
|
|
* Mon Jul 17 2023 Fabio Valentini <decathorpe@gmail.com> - 2.0.3-1
|
|
- Update to version 2.0.3; Fixes RHBZ#2223123
|
|
|
|
* Wed Jul 05 2023 Fabio Valentini <decathorpe@gmail.com> - 2.0.2-1
|
|
- Update to version 2.0.2; Fixes RHBZ#2219474
|
|
|
|
* Thu Mar 16 2023 Fabio Valentini <decathorpe@gmail.com> - 2.0.1-1
|
|
- Update to version 2.0.1; Fixes RHBZ#2175577
|
|
|
|
* Tue Feb 28 2023 Fabio Valentini <decathorpe@gmail.com> - 2.0.0-1
|
|
- Update to version 2.0.0; Fixes RHBZ#2165403
|
|
|
|
* Sun Jan 29 2023 Fabio Valentini <decathorpe@gmail.com> - 1.0.9-1
|
|
- Update to version 1.0.9; Fixes RHBZ#2165403
|
|
|
|
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.8-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
|
|
|
* Tue Dec 20 2022 Fabio Valentini <decathorpe@gmail.com> - 1.0.8-1
|
|
- Update to version 1.0.8; Fixes RHBZ#2154572
|
|
|
|
* Tue Aug 02 2022 Fabio Valentini <decathorpe@gmail.com> - 1.0.7-1
|
|
- Update to version 1.0.7; Fixes RHBZ#2113781
|
|
|
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.6-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
|
|
|
* Wed May 25 2022 Fabio Valentini <decathorpe@gmail.com> - 1.0.6-1
|
|
- Update to version 1.0.6; Fixes RHBZ#2082419
|
|
|
|
* Sat Mar 05 2022 Fabio Valentini <decathorpe@gmail.com> - 1.0.4-1
|
|
- Update to version 1.0.4; Fixes RHBZ#2055966
|
|
|
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
|
|
|
* Tue Jul 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-3
|
|
- Second attempt - Rebuilt for
|
|
https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
|
|
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
|
|
|
* Sun Dec 27 14:25:29 CET 2020 Igor Raits <igor.raits@gmail.com> - 1.0.3-1
|
|
- Initial package
|
|
|