You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
161 lines
4.7 KiB
161 lines
4.7 KiB
## START: Set by rpmautospec
|
|
## (rpmautospec version 0.3.1)
|
|
## RPMAUTOSPEC: autorelease, autochangelog
|
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
|
release_number = 4;
|
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
|
print(release_number + base_release_number - 1);
|
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
|
## END: Set by rpmautospec
|
|
|
|
# Generated by rust2rpm 20
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate indicatif
|
|
|
|
Name: rust-%{crate}0.15
|
|
Version: 0.15.0
|
|
Release: %autorelease
|
|
Summary: Progress bar and cli reporting library for Rust
|
|
|
|
# Upstream license specification: MIT
|
|
License: MIT
|
|
URL: https://crates.io/crates/indicatif
|
|
Source: %{crates_source}
|
|
# Initial patched metadata
|
|
# * bump number_prefix from 0.3 to 0.4
|
|
Patch0: indicatif-fix-metadata.diff
|
|
# * port to number_prefix 0.4:
|
|
# https://github.com/mitsuhiko/indicatif/commit/c3403b8
|
|
Patch1: 0001-port-to-number_prefix-0.4.patch
|
|
|
|
ExclusiveArch: %{rust_arches}
|
|
|
|
BuildRequires: rust-packaging
|
|
|
|
%global _description %{expand:
|
|
Progress bar and cli reporting library for Rust.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license LICENSE
|
|
%doc README.md
|
|
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
|
|
|
%package -n %{name}+improved_unicode-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+improved_unicode-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "improved_unicode" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+improved_unicode-devel
|
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
|
|
|
%package -n %{name}+rayon-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+rayon-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "rayon" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+rayon-devel
|
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
|
|
|
%package -n %{name}+unicode-segmentation-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+unicode-segmentation-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "unicode-segmentation" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+unicode-segmentation-devel
|
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
|
|
|
%package -n %{name}+unicode-width-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+unicode-width-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "unicode-width" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+unicode-width-devel
|
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
|
|
|
%package -n %{name}+with_rayon-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+with_rayon-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "with_rayon" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+with_rayon-devel
|
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.15.0-4
|
|
- Rebuilt for MSVSphere 9.3
|
|
|
|
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.15.0-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
|
|
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.15.0-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
|
|
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.15.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
|
|
|
* Wed Jan 12 2022 Fabio Valentini <decathorpe@gmail.com> - 0.15.0-1
|
|
- Initial import (indicatif 0.15 compat package)
|