You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
97 lines
2.3 KiB
97 lines
2.3 KiB
# Generated by rust2rpm 24
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate humansize
|
|
|
|
Name: rust-humansize
|
|
Version: 2.1.3
|
|
Release: %autorelease
|
|
Summary: Configurable crate to easily represent sizes in a human-readable format
|
|
|
|
# Upstream license specification: MIT/Apache-2.0
|
|
License: MIT OR Apache-2.0
|
|
URL: https://crates.io/crates/humansize
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: rust-packaging >= 21
|
|
|
|
%global _description %{expand:
|
|
A configurable crate to easily represent sizes in a human-readable
|
|
format.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-APACHE
|
|
%license %{crate_instdir}/LICENSE-MIT
|
|
%doc %{crate_instdir}/README.md
|
|
%doc %{crate_instdir}/changelog.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+impl_style-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+impl_style-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "impl_style" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+impl_style-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+no_alloc-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+no_alloc-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "no_alloc" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+no_alloc-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|