You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
206 lines
5.3 KiB
206 lines
5.3 KiB
# Generated by rust2rpm 24
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate http-auth
|
|
|
|
Name: rust-http-auth
|
|
Version: 0.1.8
|
|
Release: %autorelease
|
|
Summary: HTTP authentication
|
|
|
|
# Upstream license specification: MIT/Apache-2.0
|
|
License: MIT OR Apache-2.0
|
|
URL: https://crates.io/crates/http-auth
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: rust-packaging >= 21
|
|
|
|
%global _description %{expand:
|
|
HTTP authentication: parse challenge lists, respond to Basic and Digest
|
|
challenges. Likely to be extended with server support and additional
|
|
auth schemes.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-APACHE.txt
|
|
%license %{crate_instdir}/LICENSE-MIT.txt
|
|
%doc %{crate_instdir}/CHANGELOG.md
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+base64-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+base64-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "base64" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+base64-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+basic-scheme-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+basic-scheme-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "basic-scheme" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+basic-scheme-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+digest-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+digest-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "digest" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+digest-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+digest-scheme-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+digest-scheme-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "digest-scheme" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+digest-scheme-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+hex-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+hex-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "hex" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+hex-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+http-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+http-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "http" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+http-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+log-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+log-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "log" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+log-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+md-5-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+md-5-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "md-5" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+md-5-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+rand-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+rand-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "rand" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+rand-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+sha2-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+sha2-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "sha2" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+sha2-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+trace-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+trace-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "trace" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+trace-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|