diff --git a/rust-html5ever.spec b/rust-html5ever.spec
index f227aee..ffd3664 100644
--- a/rust-html5ever.spec
+++ b/rust-html5ever.spec
@@ -1,12 +1,12 @@
-# Generated by rust2rpm-9-1.fc31
-%bcond_with check
+# Generated by rust2rpm 10
+%bcond_without check
%global debug_package %{nil}
%global crate html5ever
Name: rust-%{crate}
Version: 0.23.0
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: High-performance browser-grade HTML5 parser
# Upstream license specification: MIT / Apache-2.0
@@ -15,26 +15,14 @@ URL: https://crates.io/crates/html5ever
Source: %{crates_source}
ExclusiveArch: %{rust_arches}
+%if %{__cargo_skip_build}
+BuildArch: noarch
+%endif
BuildRequires: rust-packaging
-BuildRequires: (crate(log/default) >= 0.4.0 with crate(log/default) < 0.5.0)
-BuildRequires: (crate(mac/default) >= 0.1.0 with crate(mac/default) < 0.2.0)
-BuildRequires: (crate(markup5ever/default) >= 0.8.0 with crate(markup5ever/default) < 0.9.0)
-BuildRequires: (crate(proc-macro2/default) >= 0.4.0 with crate(proc-macro2/default) < 0.5.0)
-BuildRequires: (crate(quote/default) >= 0.6.0 with crate(quote/default) < 0.7.0)
-BuildRequires: (crate(syn/default) >= 0.15.0 with crate(syn/default) < 0.16.0)
-BuildRequires: (crate(syn/extra-traits) >= 0.15.0 with crate(syn/extra-traits) < 0.16.0)
-BuildRequires: (crate(syn/fold) >= 0.15.0 with crate(syn/fold) < 0.16.0)
-BuildRequires: (crate(syn/full) >= 0.15.0 with crate(syn/full) < 0.16.0)
-%if %{with check}
-BuildRequires: (crate(criterion/default) >= 0.2.0 with crate(criterion/default) < 0.3.0)
-BuildRequires: (crate(rustc-serialize/default) >= 0.3.15 with crate(rustc-serialize/default) < 0.4.0)
-BuildRequires: (crate(rustc-test/default) >= 0.3.0 with crate(rustc-test/default) < 0.4.0)
-BuildRequires: (crate(typed-arena/default) >= 1.3.0 with crate(typed-arena/default) < 2.0.0)
-%endif
-%global _description \
-High-performance browser-grade HTML5 parser.
+%global _description %{expand:
+High-performance browser-grade HTML5 parser.}
%description %{_description}
@@ -67,6 +55,9 @@ which use "default" feature of "%{crate}" crate.
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
+%generate_buildrequires
+%cargo_generate_buildrequires
+
%build
%cargo_build
@@ -79,6 +70,9 @@ which use "default" feature of "%{crate}" crate.
%endif
%changelog
+* Sat Jun 22 20:01:02 CEST 2019 Igor Gnatenko - 0.23.0-2
+- Regenerate
+
* Sun May 05 12:41:32 CEST 2019 Igor Gnatenko - 0.23.0-1
- Update to 0.23.0