You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-heapless0.7/rust-heapless0.7.spec

150 lines
3.9 KiB

# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate heapless
Name: rust-heapless0.7
Version: 0.7.17
Release: %autorelease
Summary: Static friendly data structures that don't require dynamic memory allocation
License: MIT OR Apache-2.0
URL: https://crates.io/crates/heapless
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: heapless-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# can't package ufmt, test errors
Patch: heapless-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
`static` friendly data structures that don't require dynamic memory
allocation.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%doc %{crate_instdir}/suppressions.txt
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+cas-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+cas-devel %{_description}
This package contains library source intended for building other packages which
use the "cas" feature of the "%{crate}" crate.
%files -n %{name}+cas-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+mpmc_large-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+mpmc_large-devel %{_description}
This package contains library source intended for building other packages which
use the "mpmc_large" feature of the "%{crate}" crate.
%files -n %{name}+mpmc_large-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ufmt-impl-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ufmt-impl-devel %{_description}
This package contains library source intended for building other packages which
use the "ufmt-impl" feature of the "%{crate}" crate.
%files -n %{name}+ufmt-impl-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ufmt-write-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ufmt-write-devel %{_description}
This package contains library source intended for building other packages which
use the "ufmt-write" feature of the "%{crate}" crate.
%files -n %{name}+ufmt-write-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+x86-sync-pool-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+x86-sync-pool-devel %{_description}
This package contains library source intended for building other packages which
use the "x86-sync-pool" feature of the "%{crate}" crate.
%files -n %{name}+x86-sync-pool-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog