You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-half/rust-half.spec

186 lines
5.0 KiB

# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate half
Name: rust-half
Version: 2.4.1
Release: %autorelease
Summary: Half-precision floating point f16 and bf16 types for Rust
License: MIT OR Apache-2.0
URL: https://crates.io/crates/half
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: half-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency
# * allow current releases of zerocopy (0.7.x):
# https://github.com/starkat99/half-rs/pull/114
Patch: half-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Half-precision floating point f16 and bf16 types for Rust implementing
the IEEE 754-2008 standard binary16 and bfloat16 types.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bytemuck-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bytemuck-devel %{_description}
This package contains library source intended for building other packages which
use the "bytemuck" feature of the "%{crate}" crate.
%files -n %{name}+bytemuck-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+num-traits-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+num-traits-devel %{_description}
This package contains library source intended for building other packages which
use the "num-traits" feature of the "%{crate}" crate.
%files -n %{name}+num-traits-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand_distr-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand_distr-devel %{_description}
This package contains library source intended for building other packages which
use the "rand_distr" feature of the "%{crate}" crate.
%files -n %{name}+rand_distr-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rkyv-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rkyv-devel %{_description}
This package contains library source intended for building other packages which
use the "rkyv" feature of the "%{crate}" crate.
%files -n %{name}+rkyv-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+use-intrinsics-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+use-intrinsics-devel %{_description}
This package contains library source intended for building other packages which
use the "use-intrinsics" feature of the "%{crate}" crate.
%files -n %{name}+use-intrinsics-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zerocopy-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+zerocopy-devel %{_description}
This package contains library source intended for building other packages which
use the "zerocopy" feature of the "%{crate}" crate.
%files -n %{name}+zerocopy-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog