You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
76 lines
1.8 KiB
76 lines
1.8 KiB
# Generated by rust2rpm 25
|
|
# * Deactivate tests because of a missing dev-dependency (gix-testtools)
|
|
# * See https://github.com/Byron/gitoxide/discussions/900 for more information
|
|
%bcond_with check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate gix-worktree-stream
|
|
|
|
Name: rust-gix-worktree-stream
|
|
Version: 0.6.0
|
|
Release: %autorelease
|
|
Summary: Generate a byte-stream from a git-tree
|
|
|
|
License: MIT OR Apache-2.0
|
|
URL: https://crates.io/crates/gix-worktree-stream
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: cargo-rpm-macros >= 24
|
|
|
|
%global _description %{expand:
|
|
Generate a byte-stream from a git-tree.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-APACHE
|
|
%license %{crate_instdir}/LICENSE-MIT
|
|
%doc %{crate_instdir}/CHANGELOG.md
|
|
# We exclude the tests directory because they contain bash scripts
|
|
# and the automatic Requires detection falsely adds bash as a required dependency.
|
|
# Tests are disabled anyway so this should have no effect.
|
|
%exclude %{crate_instdir}/tests
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|