You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-gix-packetline/rust-gix-packetline.spec

154 lines
4.0 KiB

# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate gix-packetline
Name: rust-gix-packetline
Version: 0.17.6
Release: %autorelease
Summary: Implementation of the the pkt-line serialization format for gix
License: MIT OR Apache-2.0
URL: https://crates.io/crates/gix-packetline
Source: %{crates_source}
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A crate of the gitoxide project implementing the pkt-line serialization
format.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+async-io-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+async-io-devel %{_description}
This package contains library source intended for building other packages which
use the "async-io" feature of the "%{crate}" crate.
%files -n %{name}+async-io-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+blocking-io-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+blocking-io-devel %{_description}
This package contains library source intended for building other packages which
use the "blocking-io" feature of the "%{crate}" crate.
%files -n %{name}+blocking-io-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+document-features-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+document-features-devel %{_description}
This package contains library source intended for building other packages which
use the "document-features" feature of the "%{crate}" crate.
%files -n %{name}+document-features-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-io-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+futures-io-devel %{_description}
This package contains library source intended for building other packages which
use the "futures-io" feature of the "%{crate}" crate.
%files -n %{name}+futures-io-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-lite-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+futures-lite-devel %{_description}
This package contains library source intended for building other packages which
use the "futures-lite" feature of the "%{crate}" crate.
%files -n %{name}+futures-lite-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pin-project-lite-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pin-project-lite-devel %{_description}
This package contains library source intended for building other packages which
use the "pin-project-lite" feature of the "%{crate}" crate.
%files -n %{name}+pin-project-lite-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog