You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-gix-index/rust-gix-index.spec

97 lines
2.4 KiB

# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate gix-index
Name: rust-gix-index
Version: 0.35.0
Release: %autorelease
Summary: Git index file implementation used by gix
License: MIT OR Apache-2.0
URL: https://crates.io/crates/gix-index
Source: %{crates_source}
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A work-in-progress crate of the gitoxide project dedicated implementing
the git index file.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+document-features-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+document-features-devel %{_description}
This package contains library source intended for building other packages which
use the "document-features" feature of the "%{crate}" crate.
%files -n %{name}+document-features-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
# * Skip test that requires a not published file (tests/ directory is not
# published with the crate)
%cargo_test -- -- --skip entry_by_path_with_conflicting_file --skip size_of_entry --skip size_of_tree
%endif
%changelog
%autochangelog