Initial import (#2228219)
parent
e387a1866a
commit
e64f7351c0
@ -0,0 +1 @@
|
||||
/gix-commitgraph-0.18.1.crate
|
@ -1,3 +0,0 @@
|
||||
# rust-gix-commitgraph
|
||||
|
||||
The rust-gix-commitgraph package
|
@ -0,0 +1,13 @@
|
||||
--- gix-commitgraph-0.18.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ gix-commitgraph-0.18.1/Cargo.toml 2023-08-01T18:19:29.936921+00:00
|
||||
@@ -44,10 +44,6 @@
|
||||
features = ["std"]
|
||||
default-features = false
|
||||
|
||||
-[dependencies.document-features]
|
||||
-version = "0.2.0"
|
||||
-optional = true
|
||||
-
|
||||
[dependencies.gix-chunk]
|
||||
version = "^0.4.4"
|
||||
|
@ -0,0 +1,84 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate gix-commitgraph
|
||||
|
||||
Name: rust-gix-commitgraph
|
||||
Version: 0.18.1
|
||||
Release: %autorelease
|
||||
Summary: Read-only access to the git commitgraph file format
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/gix-commitgraph
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unused optional dependency that is only useful for building docs
|
||||
Patch: gix-commitgraph-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Read-only access to the git commitgraph file format.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue