Update to version 0.15.0 (rhbz#2307375)

epel10 imports/epel10/rust-gix-archive-0.15.0-1.el10
blinxen 4 months ago
parent 13387f564b
commit c765131f9e

1
.gitignore vendored

@ -3,3 +3,4 @@
/gix-archive-0.11.0.crate
/gix-archive-0.13.1.crate
/gix-archive-0.13.2.crate
/gix-archive-0.15.0.crate

@ -1,17 +1,17 @@
--- gix-archive-0.13.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ gix-archive-0.13.1/Cargo.toml 2024-06-01T19:27:20.047617+00:00
@@ -77,7 +77,7 @@
default-features = false
--- gix-archive-0.15.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ gix-archive-0.15.0/Cargo.toml 2024-09-07T18:05:21.490769+00:00
@@ -76,7 +76,7 @@
version = "1.0.26"
[dependencies.zip]
-version = "2.1.0"
+version = "0.6.6"
features = [
"deflate",
"time",
--- gix-archive-0.13.1/src/write.rs
+++ gix-archive-0.13.1/src/write.rs
@@ -126,7 +126,7 @@ where
features = ["deflate"]
optional = true
default-features = false
--- gix-archive-0.15.0/src/write.rs
+++ gix-archive-0.15.0/src/write.rs
@@ -126,7 +127,7 @@ where
NextFn: FnMut(&mut Stream) -> Result<Option<Entry<'_>>, gix_worktree_stream::entry::Error>,
{
let compression_level = match opts.format {
@ -20,7 +20,16 @@
_other => return write_stream(stream, next_entry, out, opts),
};
@@ -161,10 +161,10 @@ fn append_zip_entry<W: std::io::Write + std::io::Seek>(
@@ -149,7 +150,7 @@ where
zdt.minute().try_into().expect("non-negative"),
zdt.second().try_into().expect("non-negative"),
)
- .map_err(|err| Error::InvalidModificationTime(Box::new(err)))?;
+ .map_err(|_| Error::InvalidModificationTime(Box::new(zip::result::DateTimeRangeError)))?;
while let Some(entry) = next_entry(stream)? {
append_zip_entry(
&mut ar,
@@ -173,10 +174,10 @@ fn append_zip_entry<W: std::io::Write + std::io::Seek>(
mut entry: gix_worktree_stream::Entry<'_>,
buf: &mut Vec<u8>,
mtime: zip::DateTime,

@ -7,7 +7,7 @@
%global crate gix-archive
Name: rust-gix-archive
Version: 0.13.2
Version: 0.15.0
Release: %autorelease
Summary: Archive generation from of a worktree stream

@ -1 +1 @@
SHA512 (gix-archive-0.13.2.crate) = 0c765136c0aab6d203775ca4aa398520e122d192061706215d36d28ada707f411f77d2ac0f8974dc878289deff5685e9287afb32435e47fcfae0a0f83c83cbd4
SHA512 (gix-archive-0.15.0.crate) = ca2fe98ed93f8030ce388cce365fec52d58fd38ef588f14d20af7c9e021e558a34391d9c63847630adf47e627d76907ecb16734c96c011fefa8240f85f997c91

Loading…
Cancel
Save