You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-git2_0.13/SPECS/rust-git2_0.13.spec

177 lines
4.8 KiB

## START: Set by rpmautospec
## (rpmautospec version 0.3.0)
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 3;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 21
%bcond_without check
%global debug_package %{nil}
%global crate git2
Name: rust-%{crate}_0.13
Version: 0.13.25
Release: %autorelease
Summary: Bindings to libgit2 for interoperating with git repositories
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/git2
Source: %{crates_source}
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Bindings to libgit2 for interoperating with git repositories. This library is
both threadsafe and memory safe and allows both reading and writing git
repositories.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+https-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+https-devel %{_description}
This package contains library source intended for building other packages which
use the "https" feature of the "%{crate}" crate.
%files -n %{name}+https-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+openssl-probe-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+openssl-probe-devel %{_description}
This package contains library source intended for building other packages which
use the "openssl-probe" feature of the "%{crate}" crate.
%files -n %{name}+openssl-probe-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+openssl-sys-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+openssl-sys-devel %{_description}
This package contains library source intended for building other packages which
use the "openssl-sys" feature of the "%{crate}" crate.
%files -n %{name}+openssl-sys-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ssh-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ssh-devel %{_description}
This package contains library source intended for building other packages which
use the "ssh" feature of the "%{crate}" crate.
%files -n %{name}+ssh-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ssh_key_from_memory-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ssh_key_from_memory-devel %{_description}
This package contains library source intended for building other packages which
use the "ssh_key_from_memory" feature of the "%{crate}" crate.
%files -n %{name}+ssh_key_from_memory-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unstable-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unstable-devel %{_description}
This package contains library source intended for building other packages which
use the "unstable" feature of the "%{crate}" crate.
%files -n %{name}+unstable-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%if %{with check}
echo '/usr/bin/git'
%endif
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%if 0%{?el9}
# ssh-rsa keys are unsupported
%cargo_test -- -- --skip 'cred::test::ssh_key_from_memory'
%else
%cargo_test
%endif
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.13.25-3
- Rebuilt for MSVSphere 9.3
* Tue Nov 29 2022 Michel Alexandre Salim <salimma@fedoraproject.org> 0.13.25-3
- Disable ssh-rsa test on el9
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> 0.13.25-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Fri Jul 08 2022 Fabio Valentini <decathorpe@gmail.com> 0.13.25-1
- Update to version 0.13.25
* Fri Jul 08 2022 Fabio Valentini <decathorpe@gmail.com> 0.13.20-1
- Initial import (git2 0.13 compat package)