Update to 0.7.5

epel9
Josh Stone 7 years ago
parent 3281ba6cad
commit a50c77046d

1
.gitignore vendored

@ -4,3 +4,4 @@
/git2-0.6.11.crate
/git2-0.7.0.crate
/git2-0.7.1.crate
/git2-0.7.5.crate

@ -1,11 +0,0 @@
--- git2-0.7.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ git2-0.7.1/Cargo.toml 2018-06-14T08:36:27.122809+02:00
@@ -37,7 +37,7 @@
[dependencies.url]
version = "1.0"
[dev-dependencies.docopt]
-version = "0.8"
+version = "1.0"
[dev-dependencies.serde]
version = "1.0"

@ -0,0 +1,19 @@
diff --git a/src/config.rs b/src/config.rs
index b01729aebdc3..32e4d50bba55 100644
--- a/src/config.rs
+++ b/src/config.rs
@@ -452,10 +452,10 @@ impl<'cfg> ConfigEntry<'cfg> {
unsafe { ConfigLevel::from_raw((*self.raw).level) }
}
- /// Depth of includes where this variable was found
- pub fn include_depth(&self) -> u32 {
- unsafe { (*self.raw).include_depth as u32 }
- }
+ // /// Depth of includes where this variable was found
+ // pub fn include_depth(&self) -> u32 {
+ // unsafe { (*self.raw).include_depth as u32 }
+ // }
}
impl<'cfg> Binding for ConfigEntry<'cfg> {

@ -5,16 +5,16 @@
%global crate git2
Name: rust-%{crate}
Version: 0.7.1
Release: 3%{?dist}
Version: 0.7.5
Release: 1%{?dist}
Summary: Bindings to libgit2 for interoperating with git repositories
License: MIT or ASL 2.0
URL: https://crates.io/crates/git2
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump docopt to 1.0, https://github.com/alexcrichton/git2-rs/pull/319
Patch0: git2-0.7.1-fix-metadata.diff
# libgit2 0.27 doesn't have this field -- see rust-libgit2-sys
Patch1: rust-git2-no-include_depth.patch
ExclusiveArch: %{rust_arches}
@ -22,7 +22,7 @@ BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(bitflags) >= 1.0.0 with crate(bitflags) < 2.0.0)
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
BuildRequires: (crate(libgit2-sys) >= 0.7.0 with crate(libgit2-sys) < 0.8.0)
BuildRequires: (crate(libgit2-sys) >= 0.7.7 with crate(libgit2-sys) < 0.8.0)
BuildRequires: (crate(log) >= 0.4.0 with crate(log) < 0.5.0)
BuildRequires: (crate(openssl-probe) >= 0.1.0 with crate(openssl-probe) < 0.2.0)
BuildRequires: (crate(openssl-sys) >= 0.9.0 with crate(openssl-sys) < 0.10.0)
@ -32,8 +32,9 @@ BuildRequires: (crate(url) >= 1.0.0 with crate(url) < 2.0.0)
BuildRequires: (crate(docopt) >= 1.0.0 with crate(docopt) < 2.0.0)
BuildRequires: (crate(serde) >= 1.0.0 with crate(serde) < 2.0.0)
BuildRequires: (crate(serde_derive) >= 1.0.0 with crate(serde_derive) < 2.0.0)
BuildRequires: (crate(tempdir) >= 0.3.0 with crate(tempdir) < 0.4.0)
BuildRequires: (crate(time) >= 0.1.0 with crate(time) < 0.2.0)
BuildRequires: (crate(tempdir) >= 0.3.7 with crate(tempdir) < 0.4.0)
BuildRequires: (crate(thread-id) >= 3.3.0 with crate(thread-id) < 4.0.0)
BuildRequires: (crate(time) >= 0.1.39 with crate(time) < 0.2.0)
%endif
%description
@ -73,6 +74,9 @@ which use %{crate} from crates.io.
%exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml
%changelog
* Fri Aug 10 2018 Josh Stone <jistone@redhat.com> - 0.7.5-1
- Update to 0.7.5
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

@ -1 +1 @@
SHA512 (git2-0.7.1.crate) = efe7a12d877b995b8cef59c0a419f86c17453ee10a356d7b1e58cad8d3ca14e1883108b0137a3cd9b4d651d4e4233388686d91c9cdca8b1d942cfddf477f74e2
SHA512 (git2-0.7.5.crate) = 94d6ee17368a8476ff415dd4de61b02a19b756de44084a787d093323fb11692d17d30aadfc5c1037e7f70b0e5f94aa0d1b6639c9f9afa17c19d6638b7cdcee4e

Loading…
Cancel
Save