You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-gimli/gimli-fix-metadata.diff

36 lines
740 B

--- gimli-0.31.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ gimli-0.31.0/Cargo.toml 2024-07-23T18:31:46.549287+00:00
@@ -48,20 +48,6 @@
[profile.test]
split-debuginfo = "packed"
-[dependencies.alloc]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-alloc"
-
-[dependencies.compiler_builtins]
-version = "0.1.2"
-optional = true
-
-[dependencies.core]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-core"
-
[dependencies.fallible-iterator]
version = "0.3.0"
optional = true
@@ -97,11 +83,6 @@
"endian-reader",
]
read-core = []
-rustc-dep-of-std = [
- "dep:core",
- "dep:alloc",
- "dep:compiler_builtins",
-]
std = [
"fallible-iterator?/std",
"stable_deref_trait?/std",