You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-gimli/gimli-fix-metadata.diff

31 lines
834 B

--- gimli-0.23.0/Cargo.toml 2020-10-27T04:37:49+00:00
+++ gimli-0.23.0/Cargo.toml 2020-11-07T14:27:25.997187+00:00
@@ -42,19 +42,6 @@
[[example]]
name = "dwarf-validate"
required-features = ["read", "std"]
-[dependencies.alloc]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-alloc"
-
-[dependencies.compiler_builtins]
-version = "0.1.2"
-optional = true
-
-[dependencies.core]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-core"
[dependencies.fallible-iterator]
version = "0.2.0"
@@ -100,7 +87,6 @@
default = ["read", "write", "std", "fallible-iterator", "endian-reader"]
endian-reader = ["stable_deref_trait"]
read = []
-rustc-dep-of-std = ["core", "alloc", "compiler_builtins"]
std = ["fallible-iterator/std", "stable_deref_trait/std"]
write = ["indexmap"]
[badges.coveralls]