parent
e81edbd42a
commit
a1824ca2fc
@ -0,0 +1 @@
|
||||
/getch-0.2.1.crate
|
@ -0,0 +1,10 @@
|
||||
--- getch-0.2.1/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ getch-0.2.1/Cargo.toml 2020-02-14T09:44:31.273575+00:00
|
||||
@@ -21,6 +21,4 @@
|
||||
license = "Apache-2.0"
|
||||
repository = "https://nest.pijul.com/pijul_org/getch"
|
||||
[target."cfg(unix)".dependencies.termios]
|
||||
-version = "0.2"
|
||||
-[target."cfg(windows)".dependencies.libc]
|
||||
-version = "0.2"
|
||||
+version = "0.3"
|
@ -0,0 +1,77 @@
|
||||
# Generated by rust2rpm 13
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate getch
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.2.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Portable implementation of getch, using _getch on Windows, and termios on Unix
|
||||
|
||||
# Upstream license specification: Apache-2.0
|
||||
# https://nest.pijul.com/pijul_org/getch/discussions/4
|
||||
License: ASL 2.0
|
||||
URL: https://crates.io/crates/getch
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * Update termios to 0.3
|
||||
Patch0: getch-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Portable implementation of getch, using _getch on Windows, and termios on Unix.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Feb 14 10:44:31 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.2.1-1
|
||||
- Initial package
|
Loading…
Reference in new issue