You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
222 lines
7.0 KiB
222 lines
7.0 KiB
## START: Set by rpmautospec
|
|
## (rpmautospec version 0.3.5)
|
|
## RPMAUTOSPEC: autorelease, autochangelog
|
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
|
release_number = 4;
|
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
|
print(release_number + base_release_number - 1);
|
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
|
## END: Set by rpmautospec
|
|
|
|
# Generated by rust2rpm 24
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate futures
|
|
|
|
Name: rust-futures0.1
|
|
Version: 0.1.31
|
|
Release: %autorelease
|
|
Summary: Implementation of futures and streams featuring zero allocations
|
|
|
|
# Upstream license specification: MIT/Apache-2.0
|
|
License: MIT OR Apache-2.0
|
|
URL: https://crates.io/crates/futures
|
|
Source: %{crates_source}
|
|
# https://github.com/rust-lang/futures-rs/pull/2765
|
|
Patch: 0001-Fix-logic-bug-in-stream-Stream-filter_map-doctest.patch
|
|
|
|
BuildRequires: rust-packaging >= 21
|
|
|
|
%global _description %{expand:
|
|
An implementation of futures and streams featuring zero allocations,
|
|
composability, and iterator-like interfaces.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-APACHE
|
|
%license %{crate_instdir}/LICENSE-MIT
|
|
%doc %{crate_instdir}/CHANGELOG.md
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+nightly-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+nightly-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "nightly" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+nightly-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+use_std-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+use_std-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "use_std" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+use_std-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+with-deprecated-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+with-deprecated-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "with-deprecated" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+with-deprecated-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
%cargo_prep
|
|
# remove tests that are unreliable and often spin forever
|
|
rm tests/buffer_unordered.rs
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
* Fri Jan 12 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.1.31-4
|
|
- Rebuilt for MSVSphere 9.3
|
|
|
|
* Wed Jul 26 2023 Fabio Valentini <decathorpe@gmail.com> - 0.1.31-4
|
|
- Remove tests that are unreliable and often spin forever
|
|
|
|
* Sun Jul 23 2023 Fabio Valentini <decathorpe@gmail.com> - 0.1.31-3
|
|
- Fix logic bug in stream::Stream::filter_map doctest
|
|
|
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.31-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
|
|
|
* Wed May 17 2023 Fabio Valentini <decathorpe@gmail.com> - 0.1.31-1
|
|
- Update to version 0.1.31
|
|
|
|
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.29-9
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
|
|
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.29-8
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
|
|
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.29-7
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
|
|
|
* Tue Jul 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.29-6
|
|
- Second attempt - Rebuilt for
|
|
https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
|
|
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.29-5
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
|
|
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.29-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
|
|
|
* Tue Feb 18 03:44:58 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.1.29-3
|
|
- Disable tests
|
|
|
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.29-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
|
|
|
* Sat Nov 23 2019 Josh Stone <jistone@redhat.com> - 0.1.29-1
|
|
- Update to 0.1.29
|
|
|
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.27-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
|
|
|
* Sat Jun 22 10:44:49 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.27-2
|
|
- Regenerate
|
|
|
|
* Thu May 30 21:10:06 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.27-1
|
|
- Update to 0.1.27
|
|
|
|
* Tue Apr 02 2019 Josh Stone <jistone@redhat.com> - 0.1.26-1
|
|
- Update to 0.1.26
|
|
|
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.25-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
|
|
|
* Mon Nov 05 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.25-3
|
|
- Run tests in infrastructure
|
|
|
|
* Sun Nov 04 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.25-2
|
|
- Adapt to new packaging
|
|
|
|
* Mon Oct 08 2018 Josh Stone <jistone@redhat.com> - 0.1.25-1
|
|
- Update to 0.1.25
|
|
|
|
* Fri Sep 07 2018 Josh Stone <jistone@redhat.com> - 0.1.24-1
|
|
- Update to 0.1.24
|
|
|
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.21-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
|
|
|
* Sun Jul 01 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.21-3
|
|
- Stop ignoring test suite
|
|
|
|
* Fri Jun 29 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.21-2
|
|
- Fix build with new macro
|
|
|
|
* Tue Apr 03 2018 Josh Stone <jistone@redhat.com> - 0.1.21-1
|
|
- Update to 0.1.21
|
|
|
|
* Fri Mar 23 2018 Josh Stone <jistone@redhat.com> - 0.1.19-1
|
|
- Update to 0.1.19
|
|
|
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.18-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
|
|
|
* Fri Jan 26 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.18-2
|
|
- Stop running useless chmod
|
|
|
|
* Fri Jan 26 2018 Josh Stone <jistone@redhat.com> - 0.1.18-1
|
|
- Update to 0.1.18
|
|
|
|
* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.17-2
|
|
- Rebuild for rust-packaging v5
|
|
|
|
* Thu Jun 15 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.14-1
|
|
- Initial package
|
|
|