You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-futures/SOURCES/futures-fix-metadata.diff

54 lines
950 B

--- futures-0.3.31/Cargo.toml 1970-01-01T00:00:01+00:00
+++ futures-0.3.31/Cargo.toml 2024-10-13T12:15:28.585671+00:00
@@ -72,10 +72,6 @@
path = "tests/bilock.rs"
[[test]]
-name = "compat"
-path = "tests/compat.rs"
-
-[[test]]
name = "eager_drop"
path = "tests/eager_drop.rs"
@@ -317,14 +313,14 @@
[dev-dependencies.assert_matches]
version = "1.3.0"
+[dev-dependencies.futures-test]
+version = "=0.3.31"
+
[dev-dependencies.pin-project]
version = "1.0.11"
[dev-dependencies.static_assertions]
version = "1"
-
-[dev-dependencies.tokio]
-version = "0.1.11"
[features]
alloc = [
@@ -340,10 +336,6 @@
]
bilock = ["futures-util/bilock"]
cfg-target-has-atomic = []
-compat = [
- "std",
- "futures-util/compat",
-]
default = [
"std",
"async-await",
@@ -352,10 +344,6 @@
executor = [
"std",
"futures-executor/std",
-]
-io-compat = [
- "compat",
- "futures-util/io-compat",
]
std = [
"alloc",