Update to version 0.3.19; Fixes RHBZ#2033912

epel9
Fabio Valentini 3 years ago
parent 16cd75023f
commit d9a9ce3664
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -20,3 +20,4 @@
/futures-0.3.16.crate
/futures-0.3.17.crate
/futures-0.3.18.crate
/futures-0.3.19.crate

@ -1,11 +1,11 @@
--- futures-0.3.18/Cargo.toml 1970-01-01T00:00:01+00:00
+++ futures-0.3.18/Cargo.toml 2021-11-24T10:12:58.871978+00:00
--- futures-0.3.19/Cargo.toml 1970-01-01T00:00:01+00:00
+++ futures-0.3.19/Cargo.toml 2021-12-20T20:56:39.068563+00:00
@@ -60,6 +60,9 @@
[dev-dependencies.assert_matches]
version = "1.3.0"
+[dev-dependencies.futures-test]
+version = "0.3.18"
+version = "0.3.19"
+
[dev-dependencies.pin-project]
version = "1.0.1"

@ -1,11 +1,11 @@
# Generated by rust2rpm 18
# Generated by rust2rpm 20
%bcond_without check
%global debug_package %{nil}
%global crate futures
Name: rust-%{crate}
Version: 0.3.18
Version: 0.3.19
Release: %autorelease
Summary: Implementation of futures and streams
@ -18,9 +18,6 @@ Source: %{crates_source}
Patch0: futures-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
@ -36,11 +33,11 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%license LICENSE-APACHE LICENSE-MIT
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
@ -49,8 +46,8 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -61,8 +58,8 @@ BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages
which use "alloc" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -73,8 +70,8 @@ BuildArch: noarch
%description -n %{name}+async-await-devel %{_description}
This package contains library source intended for building other packages
which use "async-await" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "async-await" feature of the "%{crate}" crate.
%files -n %{name}+async-await-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -85,8 +82,8 @@ BuildArch: noarch
%description -n %{name}+bilock-devel %{_description}
This package contains library source intended for building other packages
which use "bilock" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "bilock" feature of the "%{crate}" crate.
%files -n %{name}+bilock-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -97,8 +94,8 @@ BuildArch: noarch
%description -n %{name}+cfg-target-has-atomic-devel %{_description}
This package contains library source intended for building other packages
which use "cfg-target-has-atomic" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "cfg-target-has-atomic" feature of the "%{crate}" crate.
%files -n %{name}+cfg-target-has-atomic-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -109,8 +106,8 @@ BuildArch: noarch
%description -n %{name}+compat-devel %{_description}
This package contains library source intended for building other packages
which use "compat" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "compat" feature of the "%{crate}" crate.
%files -n %{name}+compat-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -121,8 +118,8 @@ BuildArch: noarch
%description -n %{name}+executor-devel %{_description}
This package contains library source intended for building other packages
which use "executor" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "executor" feature of the "%{crate}" crate.
%files -n %{name}+executor-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -133,8 +130,8 @@ BuildArch: noarch
%description -n %{name}+futures-executor-devel %{_description}
This package contains library source intended for building other packages
which use "futures-executor" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "futures-executor" feature of the "%{crate}" crate.
%files -n %{name}+futures-executor-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -145,32 +142,20 @@ BuildArch: noarch
%description -n %{name}+io-compat-devel %{_description}
This package contains library source intended for building other packages
which use "io-compat" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "io-compat" feature of the "%{crate}" crate.
%files -n %{name}+io-compat-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+read-initializer-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+read-initializer-devel %{_description}
This package contains library source intended for building other packages
which use "read-initializer" feature of "%{crate}" crate.
%files -n %{name}+read-initializer-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -181,8 +166,8 @@ BuildArch: noarch
%description -n %{name}+thread-pool-devel %{_description}
This package contains library source intended for building other packages
which use "thread-pool" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "thread-pool" feature of the "%{crate}" crate.
%files -n %{name}+thread-pool-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -193,8 +178,8 @@ BuildArch: noarch
%description -n %{name}+unstable-devel %{_description}
This package contains library source intended for building other packages
which use "unstable" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "unstable" feature of the "%{crate}" crate.
%files -n %{name}+unstable-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -205,8 +190,8 @@ BuildArch: noarch
%description -n %{name}+write-all-vectored-devel %{_description}
This package contains library source intended for building other packages
which use "write-all-vectored" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "write-all-vectored" feature of the "%{crate}" crate.
%files -n %{name}+write-all-vectored-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

@ -1 +1 @@
SHA512 (futures-0.3.18.crate) = 2e5bdc685fe1b7976f9f60d99a6b1c27a3c300744de9d7d14e26510f8f591d282a7c11ef99bafb4971f5a550cc6668c493c8c29a9f94e47fabe59aeb45a41f10
SHA512 (futures-0.3.19.crate) = 2383a0ee128e9945da2b0ba50795d6efef0bec832dff3bc7d9f6f592bd120538c62b5068156f330c72779f8ce3b3a339cdc04634fef3f985eb1ce4033a7c9518

Loading…
Cancel
Save