diff --git a/.gitignore b/.gitignore
index ff5cf62..bdb14e2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -16,3 +16,4 @@
 /futures-task-0.3.18.crate
 /futures-task-0.3.19.crate
 /futures-task-0.3.21.crate
+/futures-task-0.3.23.crate
diff --git a/rust-futures-task.spec b/rust-futures-task.spec
index c39b38d..57d27f7 100644
--- a/rust-futures-task.spec
+++ b/rust-futures-task.spec
@@ -1,23 +1,22 @@
-# Generated by rust2rpm 20
+# Generated by rust2rpm 22
 # * tests can only be run in-tree
 %bcond_with check
 %global debug_package %{nil}
 
 %global crate futures-task
 
-Name:           rust-%{crate}
-Version:        0.3.21
+Name:           rust-futures-task
+Version:        0.3.23
 Release:        %autorelease
 Summary:        Tools for working with tasks
 
-# Upstream license specification: MIT OR Apache-2.0
-License:        MIT or ASL 2.0
+License:        MIT OR Apache-2.0
 URL:            https://crates.io/crates/futures-task
 Source:         %{crates_source}
 
 ExclusiveArch:  %{rust_arches}
 
-BuildRequires:  rust-packaging
+BuildRequires:  rust-packaging >= 21
 
 %global _description %{expand:
 Tools for working with tasks.}
@@ -34,9 +33,10 @@ This package contains library source intended for building other packages which
 use the "%{crate}" crate.
 
 %files          devel
-%license LICENSE-APACHE LICENSE-MIT
-%doc README.md
-%{cargo_registry}/%{crate}-%{version_no_tilde}/
+%license %{crate_instdir}/LICENSE-APACHE
+%license %{crate_instdir}/LICENSE-MIT
+%doc %{crate_instdir}/README.md
+%{crate_instdir}/
 
 %package     -n %{name}+default-devel
 Summary:        %{summary}
@@ -48,7 +48,7 @@ This package contains library source intended for building other packages which
 use the "default" feature of the "%{crate}" crate.
 
 %files       -n %{name}+default-devel
-%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+%ghost %{crate_instdir}/Cargo.toml
 
 %package     -n %{name}+alloc-devel
 Summary:        %{summary}
@@ -60,7 +60,7 @@ This package contains library source intended for building other packages which
 use the "alloc" feature of the "%{crate}" crate.
 
 %files       -n %{name}+alloc-devel
-%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+%ghost %{crate_instdir}/Cargo.toml
 
 %package     -n %{name}+cfg-target-has-atomic-devel
 Summary:        %{summary}
@@ -72,7 +72,7 @@ This package contains library source intended for building other packages which
 use the "cfg-target-has-atomic" feature of the "%{crate}" crate.
 
 %files       -n %{name}+cfg-target-has-atomic-devel
-%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+%ghost %{crate_instdir}/Cargo.toml
 
 %package     -n %{name}+std-devel
 Summary:        %{summary}
@@ -84,7 +84,7 @@ This package contains library source intended for building other packages which
 use the "std" feature of the "%{crate}" crate.
 
 %files       -n %{name}+std-devel
-%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+%ghost %{crate_instdir}/Cargo.toml
 
 %package     -n %{name}+unstable-devel
 Summary:        %{summary}
@@ -96,7 +96,7 @@ This package contains library source intended for building other packages which
 use the "unstable" feature of the "%{crate}" crate.
 
 %files       -n %{name}+unstable-devel
-%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+%ghost %{crate_instdir}/Cargo.toml
 
 %prep
 %autosetup -n %{crate}-%{version_no_tilde} -p1
diff --git a/sources b/sources
index c4c6191..dc16fbb 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (futures-task-0.3.21.crate) = 8f3b27865d8c7a290471903297e3c0b52caebfaa55550a4738d7915008b893fce67c7d9ae5c5bd03f2a42ee72a96aa0245c4bee70fc06977b3493eb81bca2033
+SHA512 (futures-task-0.3.23.crate) = 91a2f8e7f00225f1cf3198fac193171c4eb5aaaf99f9163797e9f3290f0748073688899323bd7e5effae33c286561c7fc74886e4f2caafcf6991d69e80864c29