You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-futures-lite/rust-futures-lite.spec

157 lines
3.9 KiB

# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}
%global crate futures-lite
Name: rust-futures-lite
Version: 2.6.0
Release: %autorelease
Summary: Futures, streams, and async I/O combinators
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/futures-lite
Source: %{crates_source}
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Futures, streams, and async I/O combinators.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%license %{crate_instdir}/LICENSE-THIRD-PARTY
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/FEATURES.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fastrand-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fastrand-devel %{_description}
This package contains library source intended for building other packages which
use the "fastrand" feature of the "%{crate}" crate.
%files -n %{name}+fastrand-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-io-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+futures-io-devel %{_description}
This package contains library source intended for building other packages which
use the "futures-io" feature of the "%{crate}" crate.
%files -n %{name}+futures-io-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+memchr-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+memchr-devel %{_description}
This package contains library source intended for building other packages which
use the "memchr" feature of the "%{crate}" crate.
%files -n %{name}+memchr-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+parking-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+parking-devel %{_description}
This package contains library source intended for building other packages which
use the "parking" feature of the "%{crate}" crate.
%files -n %{name}+parking-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+race-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+race-devel %{_description}
This package contains library source intended for building other packages which
use the "race" feature of the "%{crate}" crate.
%files -n %{name}+race-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog