Switched to -preview for some unknown time

epel9
Igor Gnatenko 6 years ago
parent 829711bbd1
commit 7059b9e22f

2
.gitignore vendored

@ -1,2 +0,0 @@
/futures-io-0.2.1.crate
/futures-io-0.2.2.crate

@ -1,3 +0,0 @@
# rust-futures-io
The rust-futures-io package

@ -0,0 +1 @@
Switched to -preview for some unknown time

@ -1,26 +0,0 @@
--- futures-io-preview-0.2.2/Cargo.toml 1970-01-01T01:00:00+01:00
+++ futures-io-preview-0.2.2/Cargo.toml 2018-09-11T00:22:30.383567+02:00
@@ -11,7 +11,7 @@
# will likely look very different (and much more reasonable)
[package]
-name = "futures-io-preview"
+name = "futures-io"
version = "0.2.2"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
description = "The `AsyncRead` and `AsyncWrite` traits for the futures-rs library.\n"
@@ -22,7 +22,7 @@
[lib]
name = "futures_io"
-[dependencies.futures-core-preview]
+[dependencies.futures-core]
version = "0.2.2"
default-features = false
@@ -32,4 +32,4 @@
[features]
default = ["std"]
-std = ["futures-core-preview/std", "iovec"]
+std = ["futures-core/std", "iovec"]

@ -1,71 +0,0 @@
# Generated by rust2rpm
%bcond_without check
%global debug_package %{nil}
%global crate futures-io
%global real_crate futures-io-preview
Name: rust-%{crate}
Version: 0.2.2
Release: 2%{?dist}
Summary: `AsyncRead` and `AsyncWrite` traits for the futures-rs library
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/futures-io-preview
Source0: https://crates.io/api/v1/crates/%{real_crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Remove -preview suffix
Patch0: futures-io-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(futures-core) >= 0.2.2 with crate(futures-core) < 0.3.0)
BuildRequires: (crate(iovec) >= 0.1.0 with crate(iovec) < 0.2.0)
%description
%{summary}.
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel
The `AsyncRead` and `AsyncWrite` traits for the futures-rs library.
This package contains library source intended for building other packages
which use %{crate} from crates.io.
%prep
%autosetup -n %{real_crate}-%{version} -p1
%cargo_prep
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%files devel
%license LICENSE-MIT LICENSE-APACHE
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Tue Sep 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.2-1
- Update to 0.2.2
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Mon May 21 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-1
- Initial package

@ -1 +0,0 @@
SHA512 (futures-io-0.2.2.crate) = 15867e00a4a43932709f593006353ad9eab8b76c1c85bf54399a4fd35497f30d64b3d6529d1b866ac1d78c02d36039558e4697eaf96f1a65464dcd948413a993
Loading…
Cancel
Save