Update to 0.3.1

epel9
Josh Stone 5 years ago
parent 5535478a06
commit 20a9ca1500

1
.gitignore vendored

@ -1,2 +1,3 @@
/futures-core-0.2.1.crate
/futures-core-0.2.3.crate
/futures-core-0.3.1.crate

@ -1,11 +0,0 @@
--- futures-core-preview-0.2.3/Cargo.toml 1970-01-01T01:00:00+01:00
+++ futures-core-preview-0.2.3/Cargo.toml 2018-09-11T00:16:55.597479+02:00
@@ -11,7 +11,7 @@
# will likely look very different (and much more reasonable)
[package]
-name = "futures-core-preview"
+name = "futures-core"
version = "0.2.3"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
description = "The core traits and types in for the `futures` library.\n"

@ -1,46 +1,88 @@
# Generated by rust2rpm
%bcond_without check
# Generated by rust2rpm 11
# dependency loop with futures
%bcond_with check
%global debug_package %{nil}
%global crate futures-core
%global real_crate futures-core-preview
Name: rust-%{crate}
Version: 0.2.3
Release: 3%{?dist}
Version: 0.3.1
Release: 1%{?dist}
Summary: Core traits and types in for the `futures` library
# Upstream license specification: MIT/Apache-2.0
# Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/futures-core-preview
Source0: https://crates.io/api/v1/crates/%{real_crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Remove -preview suffix
Patch0: futures-core-fix-metadata.diff
URL: https://crates.io/crates/futures-core
Source: %{crates_source}
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(either) >= 1.4.0 with crate(either) < 2.0.0)
%description
%{summary}.
%global _description %{expand:
Core traits and types in for the `futures` library.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel
The core traits and types in for the `futures` library.
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%{cargo_registry}/%{crate}-%{version}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages
which use %{crate} from crates.io.
which use "alloc" feature of "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{real_crate}-%{version} -p1
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
@ -52,11 +94,10 @@ which use %{crate} from crates.io.
%cargo_test
%endif
%files devel
%license LICENSE-MIT LICENSE-APACHE
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Tue Dec 10 2019 Josh Stone <jistone@redhat.com> - 0.3.1-1
- Update to 0.3.1
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

@ -1 +1 @@
SHA512 (futures-core-0.2.3.crate) = b5363d72bbf65513a8324e8371a64353bd9934d5f5fd7b9697fcd4a6fa7216ad4f9249fc472d3190d8e02b1d179d144d972e1548dd0935031166056d6a2e3ed5
SHA512 (futures-core-0.3.1.crate) = 6085d79e2d08678b69e729099032472127de7df106fe5fe3673c32e76dcce45550a697854587f50e074ba34ef487eca61c4933119dacd536a482176c7693f603

Loading…
Cancel
Save