Revert "Switched to -preview for some unknown time"

This reverts commit f13cc226cd.

References: https://bugzilla.redhat.com/show_bug.cgi?id=1783474
Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 5 years ago
parent f13cc226cd
commit 0ff8c272ef
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

2
.gitignore vendored

@ -0,0 +1,2 @@
/futures-channel-0.2.1.crate
/futures-channel-0.2.2.crate

@ -0,0 +1,3 @@
# rust-futures-channel
The rust-futures-channel package

@ -1 +0,0 @@
Switched to -preview for some unknown time

@ -0,0 +1,24 @@
--- futures-channel-preview-0.2.2/Cargo.toml 1970-01-01T01:00:00+01:00
+++ futures-channel-preview-0.2.2/Cargo.toml 2018-09-11T00:25:14.248096+02:00
@@ -11,7 +11,7 @@
# will likely look very different (and much more reasonable)
[package]
-name = "futures-channel-preview"
+name = "futures-channel"
version = "0.2.2"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
description = "Channels for asynchronous communication using futures-rs.\n"
@@ -22,10 +22,10 @@
[lib]
name = "futures_channel"
-[dependencies.futures-core-preview]
+[dependencies.futures-core]
version = "0.2.2"
default-features = false
[features]
default = ["std"]
-std = ["futures-core-preview/std"]
+std = ["futures-core/std"]

@ -0,0 +1,72 @@
# Generated by rust2rpm
# * Broken tests out of the git repo
# https://github.com/rust-lang-nursery/futures-rs/issues/1017
%bcond_with check
%global debug_package %{nil}
%global crate futures-channel
%global real_crate futures-channel-preview
Name: rust-%{crate}
Version: 0.2.2
Release: 2%{?dist}
Summary: Channels for asynchronous communication using futures-rs
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/futures-channel-preview
Source0: https://crates.io/api/v1/crates/%{real_crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Remove -preview suffix
Patch0: futures-channel-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(futures-core) >= 0.2.2 with crate(futures-core) < 0.3.0)
%description
%{summary}.
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel
Channels for asynchronous communication using futures-rs.
This package contains library source intended for building other packages
which use %{crate} from crates.io.
%prep
%autosetup -n %{real_crate}-%{version} -p1
%cargo_prep
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%files devel
%license LICENSE-MIT LICENSE-APACHE
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Tue Sep 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.2-1
- Update to 0.2.2
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Mon May 21 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-1
- Initial package

@ -0,0 +1 @@
SHA512 (futures-channel-0.2.2.crate) = 90d9f041926084727f1ee72c5354563ed6cbb1ff3e8abe0fa0c5ecd477c0669c1d3df1074920a5750c1a463a6bb615d6c1972e7a4af43286572a33ab970fe835
Loading…
Cancel
Save