From 09f25edcdda77c4698e29d3d5f54e47b55f2b4d0 Mon Sep 17 00:00:00 2001
From: Link Dupont
Date: Mon, 15 Nov 2021 14:39:31 -0500
Subject: [PATCH] initial package
Relates: RHBZ#2022214
---
.gitignore | 1 +
rust-find-crate.spec | 75 ++++++++++++++++++++++++++++++++++++++++++++
sources | 1 +
3 files changed, 77 insertions(+)
create mode 100644 .gitignore
create mode 100644 rust-find-crate.spec
create mode 100644 sources
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..256b6c6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/find-crate-0.6.3.crate
diff --git a/rust-find-crate.spec b/rust-find-crate.spec
new file mode 100644
index 0000000..3db5088
--- /dev/null
+++ b/rust-find-crate.spec
@@ -0,0 +1,75 @@
+# Generated by rust2rpm 18
+%bcond_without check
+%global debug_package %{nil}
+
+%global crate find-crate
+
+Name: rust-%{crate}
+Version: 0.6.3
+Release: 1%{?dist}
+Summary: Find the crate name from the current Cargo.toml
+
+# Upstream license specification: Apache-2.0 OR MIT
+License: ASL 2.0 or MIT
+URL: https://crates.io/crates/find-crate
+Source: %{crates_source}
+
+ExclusiveArch: %{rust_arches}
+%if %{__cargo_skip_build}
+BuildArch: noarch
+%endif
+
+BuildRequires: rust-packaging
+
+%global _description %{expand:
+Find the crate name from the current Cargo.toml.}
+
+%description %{_description}
+
+%package devel
+Summary: %{summary}
+BuildArch: noarch
+
+%description devel %{_description}
+
+This package contains library source intended for building other packages
+which use "%{crate}" crate.
+
+%files devel
+%license LICENSE-MIT LICENSE-APACHE
+%doc README.md CHANGELOG.md
+%{cargo_registry}/%{crate}-%{version_no_tilde}/
+
+%package -n %{name}+default-devel
+Summary: %{summary}
+BuildArch: noarch
+
+%description -n %{name}+default-devel %{_description}
+
+This package contains library source intended for building other packages
+which use "default" feature of "%{crate}" crate.
+
+%files -n %{name}+default-devel
+%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+
+%prep
+%autosetup -n %{crate}-%{version_no_tilde} -p1
+%cargo_prep
+
+%generate_buildrequires
+%cargo_generate_buildrequires
+
+%build
+%cargo_build
+
+%install
+%cargo_install
+
+%if %{with check}
+%check
+%cargo_test
+%endif
+
+%changelog
+* Sun Oct 03 2021 Link Dupont - 0.6.3-1
+- Initial package
diff --git a/sources b/sources
new file mode 100644
index 0000000..e78294f
--- /dev/null
+++ b/sources
@@ -0,0 +1 @@
+SHA512 (find-crate-0.6.3.crate) = f7866a4f917df064277630570f987898e465dce98be548ff7535201ada88b5db71c755f00013fcfed45ffdf29fd667c90ff19999a1fb7cb183a7007bd011f899