commit
59be510a30
@ -0,0 +1 @@
|
||||
SOURCES/fern-0.6.2.crate
|
@ -0,0 +1 @@
|
||||
ad4407d01aaf081eb1ae73e17f430fda77815eb1 SOURCES/fern-0.6.2.crate
|
@ -0,0 +1,22 @@
|
||||
--- fern-0.6.2/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ fern-0.6.2/Cargo.toml 2024-11-06T12:34:13.746940+00:00
|
||||
@@ -39,9 +39,6 @@
|
||||
|
||||
[package.metadata.docs.rs]
|
||||
all-features = true
|
||||
-
|
||||
-[[example]]
|
||||
-name = "cmd-program"
|
||||
|
||||
[[example]]
|
||||
name = "date-based-file-log"
|
||||
@@ -86,9 +83,6 @@
|
||||
[dependencies.log]
|
||||
version = "0.4"
|
||||
features = ["std"]
|
||||
-
|
||||
-[dev-dependencies.clap]
|
||||
-version = "2.22"
|
||||
|
||||
[dev-dependencies.humantime]
|
||||
version = "2.1.0"
|
@ -0,0 +1,26 @@
|
||||
[package]
|
||||
cargo-toml-patch-comments = [
|
||||
"drop example-only dependency on clap ^2",
|
||||
]
|
||||
|
||||
[features]
|
||||
hide = [
|
||||
"colored",
|
||||
"reopen03",
|
||||
"reopen1",
|
||||
"reopen-03",
|
||||
"reopen-1",
|
||||
"syslog3",
|
||||
"syslog4",
|
||||
"syslog6",
|
||||
"syslog-3",
|
||||
"syslog-4",
|
||||
"syslog-6",
|
||||
]
|
||||
|
||||
[scripts]
|
||||
prep.post = [
|
||||
"# drop one example program that pulls in clap ^2",
|
||||
"rm examples/cmd-program.rs",
|
||||
]
|
||||
|
@ -0,0 +1,139 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.7.3)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 26
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate fern
|
||||
|
||||
Name: rust-fern0.6
|
||||
Version: 0.6.2
|
||||
Release: %autorelease
|
||||
Summary: Simple, efficient logging
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/fern
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop example-only dependency on clap ^2
|
||||
Patch: fern-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Simple, efficient logging.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/CONTRIBUTING.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+chrono-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+chrono-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "chrono" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+chrono-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+date-based-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+date-based-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "date-based" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+date-based-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+libc-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+libc-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "libc" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+libc-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+meta-logging-in-format-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+meta-logging-in-format-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "meta-logging-in-format" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+meta-logging-in-format-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
# drop one example program that pulls in clap ^2
|
||||
rm examples/cmd-program.rs
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.6.2-1
|
||||
- Rebuilt for MSVSphere 10
|
||||
|
||||
## START: Generated by rpmautospec
|
||||
* Sat Nov 09 2024 Fabio Valentini <decathorpe@gmail.com> - 0.6.2-1
|
||||
- Initial import (fern 0.6 compat package)
|
||||
## END: Generated by rpmautospec
|
Loading…
Reference in new issue